summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-06-08 12:28:36 -0700
committerChris Larson <chris_larson@mentor.com>2010-06-08 12:28:36 -0700
commit49b8bab706c59e93287f8540187b62ba3ece0a11 (patch)
tree9e3837983f6c584441416b4276e62ab682eefab8 /bin/bitbake
parente07f759dae96c0819c35bb67e1da18ca361bb584 (diff)
downloadbitbake-contrib-49b8bab706c59e93287f8540187b62ba3ece0a11.tar.gz
Reorganize the main exception handling so an attribute exception raised in the ui isn't misinterpreted
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake13
1 files changed, 8 insertions, 5 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 505b9b4f0..126c254c0 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -87,7 +87,7 @@ warnings.simplefilter("ignore", DeprecationWarning)
#============================================================================#
def main():
- return_value = 0
+ return_value = 1
parser = optparse.OptionParser(
version = "BitBake Build Tool Core version %s, %%prog version %s" % (bb.__version__, __version__),
@@ -198,13 +198,16 @@ Default BBFILES are the .bb files in the current directory.""")
# suggest a fixed set this allows you to have flexibility in which
# ones are available.
uimodule = __import__("bb.ui", fromlist = [ui])
- return_value = getattr(uimodule, ui).init(serverConnection.connection, serverConnection.events)
+ ui_init = getattr(uimodule, ui).init
except AttributeError:
print "FATAL: Invalid user interface '%s' specified. " % ui
print "Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'."
- except Exception, e:
- print "FATAL: Unable to start to '%s' UI: %s" % (configuration.ui, e)
- raise
+ else:
+ try:
+ return_value = ui_init(serverConnection.connection, serverConnection.events)
+ except Exception, e:
+ print "FATAL: Unable to start to '%s' UI: %s" % (ui, e)
+ raise
finally:
serverConnection.terminate()
return return_value