summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-06-04 16:44:07 -0700
committerChris Larson <chris_larson@mentor.com>2010-06-04 16:44:09 -0700
commitacca7eb8450cbe30d65b5b266f1a642e7965df8a (patch)
tree5ca06db294d38261dd2c4afccfcd049a2a60dd6d /bin/bitbake
parent34f396e749303367e657911bf10c43086dff7552 (diff)
downloadbitbake-contrib-acca7eb8450cbe30d65b5b266f1a642e7965df8a.tar.gz
Adjust the exception handling based on Cliff Brake's patch
Rather than printing the exception ourselves, might as well re-raise and let the default exception handler do it for us. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake3
1 files changed, 2 insertions, 1 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 8ff275100..505b9b4f0 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -203,7 +203,8 @@ Default BBFILES are the .bb files in the current directory.""")
print "FATAL: Invalid user interface '%s' specified. " % ui
print "Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'."
except Exception, e:
- print "FATAL: Unable to start to '%s' UI due to exception: %s." % (configuration.ui, e)
+ print "FATAL: Unable to start to '%s' UI: %s" % (configuration.ui, e)
+ raise
finally:
serverConnection.terminate()
return return_value