summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-22 16:22:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-25 12:47:26 +0100
commitb133b2e2dd5bcde705397eb38fa20a5c4da6e3b3 (patch)
tree381a23c5939389e8f31d6f9992b0c9fcef2350f1 /bin/bitbake
parentf7f68847dd165f2ad0f39011db4ebfef3ae73f42 (diff)
downloadbitbake-contrib-b133b2e2dd5bcde705397eb38fa20a5c4da6e3b3.tar.gz
add note to -b option indicating no dependency handling
The -b option doesn't handle dependencies so note this in the help. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake2
1 files changed, 1 insertions, 1 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 206d97b22..f198fd155 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -102,7 +102,7 @@ It expects that BBFILES is defined, which is a space separated list of files to
be executed. BBFILES does support wildcards.
Default BBFILES are the .bb files in the current directory.""")
- parser.add_option("-b", "--buildfile", help = "execute the task against this .bb file, rather than a package from BBFILES.",
+ parser.add_option("-b", "--buildfile", help = "execute the task against this .bb file, rather than a package from BBFILES. Does not handle any dependencies.",
action = "store", dest = "buildfile", default = None)
parser.add_option("-k", "--continue", help = "continue as much as possible after an error. While the target that failed, and those that depend on it, cannot be remade, the other dependencies of these targets can be processed all the same.",