summaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2016-01-27 18:23:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-29 17:02:10 +0000
commit023a5b69df05adce0ed192b393b45eb879c096a0 (patch)
tree0dbe54cd76e84dac0a50ff32a28976937527e234 /doc
parent2c778ad50aceaffb855baf5f4aa0fed98c880870 (diff)
downloadbitbake-contrib-023a5b69df05adce0ed192b393b45eb879c096a0.tar.gz
bitbake-user-manual-ref-variables: Update the help for BBMASK
Update the help for BBMASK to reflect that it is now allowed to contain multiple regular expressions. Also changed the examples for BBMASK to be a bit more diverse. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'doc')
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml20
1 files changed, 9 insertions, 11 deletions
diff --git a/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml b/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
index e5aeffcff..ae7e4cee8 100644
--- a/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
@@ -1142,14 +1142,14 @@
to "hide" these <filename>.bb</filename> and
<filename>.bbappend</filename> files.
BitBake ignores any recipe or recipe append files that
- match the expression.
+ match any of the expressions.
It is as if BitBake does not see them at all.
Consequently, matching files are not parsed or otherwise
used by BitBake.</para>
<para>
- The value you provide is passed to Python's regular
+ The values you provide are passed to Python's regular
expression compiler.
- The expression is compared against the full paths to
+ The expressions are compared against the full paths to
the files.
For complete syntax information, see Python's
documentation at
@@ -1165,18 +1165,16 @@
BBMASK = "meta-ti/recipes-misc/"
</literallayout>
If you want to mask out multiple directories or recipes,
- use the vertical bar to separate the regular expression
- fragments.
+ you can specify multiple regular expression fragments.
This next example masks out multiple directories and
individual recipes:
<literallayout class='monospaced'>
- BBMASK = "meta-ti/recipes-misc/|meta-ti/recipes-ti/packagegroup/"
- BBMASK .= "|.*meta-oe/recipes-support/"
- BBMASK .= "|.*openldap"
- BBMASK .= "|.*opencv"
- BBMASK .= "|.*lzma"
+ BBMASK += "/meta-ti/recipes-misc/ meta-ti/recipes-ti/packagegroup/"
+ BBMASK += "/meta-oe/recipes-support/"
+ BBMASK += "/meta-foo/.*/openldap"
+ BBMASK += "opencv.*\.bbappend"
+ BBMASK += "lzma"
</literallayout>
- Notice how the vertical bar is used to append the fragments.
<note>
When specifying a directory name, use the trailing
slash character to ensure you match just that directory