summaryrefslogtreecommitdiffstats
path: root/lib/bb/command.py
diff options
context:
space:
mode:
authorCristiana Voicu <cristiana.voicu@intel.com>2012-12-12 13:51:51 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-14 13:06:16 +0000
commit22007cf71a00fbb03b40f97201a6eb06c9aebd16 (patch)
tree9a036ec72e124142013da97653c90d53dd966b35 /lib/bb/command.py
parent4a36a1af71530afc8fa896271fa94362ead176bd (diff)
downloadbitbake-contrib-22007cf71a00fbb03b40f97201a6eb06c9aebd16.tar.gz
hob/bitbake: custom image is now using the base image
Till now, a custom image made in Hob was using only the packages from the base image. Now it is using everything declared in the base image. Also next to hob-image.bb, it creates another .bb file which is used in building process. Those images are ignored by git. [YOCTO #2601] Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/command.py')
-rw-r--r--lib/bb/command.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/bb/command.py b/lib/bb/command.py
index c842497e6..0fed25a3e 100644
--- a/lib/bb/command.py
+++ b/lib/bb/command.py
@@ -200,6 +200,16 @@ class CommandsSync:
filterfunc = params[0]
bb.parse.parse_py.ConfHandler.confFilters.append(filterfunc)
+ def matchFile(self, command, params):
+ fMatch = params[0]
+ return command.cooker.matchFile(fMatch)
+
+ def generateNewImage(self, command, params):
+ image = params[0]
+ base_image = params[1]
+ package_queue = params[2]
+ return command.cooker.generateNewImage(image, base_image, package_queue)
+
class CommandsAsync:
"""
A class of asynchronous commands