aboutsummaryrefslogtreecommitdiffstats
path: root/org.openembedded.bc.ui/local.conf
diff options
context:
space:
mode:
Diffstat (limited to 'org.openembedded.bc.ui/local.conf')
-rw-r--r--org.openembedded.bc.ui/local.conf125
1 files changed, 125 insertions, 0 deletions
diff --git a/org.openembedded.bc.ui/local.conf b/org.openembedded.bc.ui/local.conf
new file mode 100644
index 0000000..de47a9e
--- /dev/null
+++ b/org.openembedded.bc.ui/local.conf
@@ -0,0 +1,125 @@
+# Where to cache the files Poky downloads
+DL_DIR ?= "${OEROOT}/sources"
+
+BBPATH += "${OEROOT}/meta-bug/*/*.bb \
+ ${OEROOT}/meta-oe/*/*.bb \
+ "
+
+# Poky has various extra metadata collections (openmoko, extras).
+# To enable these, uncomment all (or some of) the following lines:
+BBFILES = "\
+ ${OEROOT}/meta/packages/*/*.bb \
+ ${OEROOT}/meta-bug/packages/*/*.bb \
+ ${OEROOT}/meta-oe/packages/*/*.bb \
+ ${OEROOT}/meta-jalimo/packages/*/*.bb \
+ ${OEROOT}/meta-extras/packages/*/*.bb \
+ "
+BBFILE_COLLECTIONS = "normal bug"
+BBFILE_PATTERN_normal = "^${OEROOT}/meta/"
+BBFILE_PATTERN_bug = "^${OEROOT}/meta-bug/"
+BBFILE_PRIORITY_normal = "5"
+BBFILE_PRIORITY_bug = "5"
+
+
+BBMASK = ""
+
+# The machine to target
+MACHINE ?= "bug"
+# Other supported machines
+#MACHINE ?= "qemux86"
+
+DISTRO ?= "poky"
+# For bleeding edge / experimental / unstable package versions
+# DISTRO ?= "poky-bleeding"
+
+# EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images
+# (Some of these are automatically added to certain image types)
+# "dbg-pkgs" - add -dbg packages for all installed packages
+# (adds symbol information for debugging/profiling)
+# "dev-pkgs" - add -dev packages for all installed packages
+# (useful if you want to develop against libs in the image)
+# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
+# "tools-debug" - add debugging tools (gdb, strace)
+# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
+# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
+# "debug-tweaks" - make an image for suitable of development
+# e.g. ssh root access has a blank password
+# There are other application targets too, see meta/classes/poky-image.bbclass
+# and meta/packages/tasks/task-poky.bb for more details.
+
+EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
+
+EXTRA_IMAGE_FEATURES_mx31ads = "tools-testapps debug-tweaks"
+
+# A list of packaging systems used in generated images
+# The first package type listed will be used for rootfs generation
+# include 'package_deb' for debs
+# include 'package_ipk' for ipks
+#PACKAGE_CLASSES ?= "package_deb package_ipk"
+PACKAGE_CLASSES ?= "package_ipk"
+
+# POKYMODE controls the characteristics of the generated packages/images by
+# telling poky which type of toolchain to use.
+#
+# Options include several different EABI combinations and a compatibility
+# mode for the OABI mode poky previously used.
+#
+# The default is "eabi"
+# Use "oabi" for machines with kernels < 2.6.18 on ARM for example.
+# Use "external-MODE" to use the precompiled external toolchains where MODE
+# is the type of external toolchain to use e.g. eabi.
+# POKYMODE = "external-eabi"
+
+# Uncomment this to specify where BitBake should create its temporary files.
+# Note that a full build of everything in OpenEmbedded will take GigaBytes of hard
+# disk space, so make sure to free enough space. The default TMPDIR is
+# <build directory>/tmp
+TMPDIR = "${OEROOT}/build/tmp"
+
+# Uncomment and set to allow bitbake to execute multiple tasks at once.
+# Note, This option is currently experimental - YMMV.
+# BB_NUMBER_THREADS = "1"
+# Also, make can be passed flags so it run parallel threads e.g.:
+PARALLEL_MAKE = "-j 2"
+
+# Uncomment this if you are using the Openedhand provided qemu deb - see README
+# ASSUME_PROVIDED += "qemu-native"
+
+IMAGE_LINGUAS = "en-us"
+LIMIT_BUILT_LOCALES = "en_US"
+ENABLE_BINARY_LOCALE_GENERATION = "0"
+
+# Comment this out if you don't have a 3.x gcc version available and wish
+# poky to build one for you. The 3.x gcc is required to build qemu-native.
+# ASSUME_PROVIDED += "gcc3-native"
+
+# Uncomment these two if you want BitBake to build images useful for debugging.
+# DEBUG_BUILD = "1"
+# INHIBIT_PACKAGE_STRIP = "1"
+
+# Uncomment these to build a package such that you can use gprof to profile it.
+# NOTE: This will only work with 'linux' targets, not
+# 'linux-uclibc', as uClibc doesn't provide the necessary
+# object files. Also, don't build glibc itself with these
+# flags, or it'll fail to build.
+#
+# PROFILE_OPTIMIZATION = "-pg"
+# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}"
+# LDFLAGS =+ "-pg"
+
+# Uncomment this if you want BitBake to emit debugging output
+# BBDEBUG = "yes"
+# Uncomment this if you want BitBake to emit the log if a build fails.
+BBINCLUDELOGS = "yes"
+
+# Specifies a location to search for pre-generated tarballs when fetching
+# a cvs:// URI. Uncomment this, if you not want to pull directly from CVS.
+# CVS_TARBALL_STASH = "http://folks.o-hand.com/~richard/poky/sources/"
+
+# Set this if you wish to make pkgconfig libraries from your system available
+# for native builds. Combined with extra ASSUME_PROVIDEDs this can allow
+# native builds of applications like oprofileui-native (unsupported feature).
+#EXTRA_NATIVE_PKGCONFIG_PATH = ":/usr/lib/pkgconfig"
+#ASSUME_PROVIDED += "gtk+-native libglade-native"
+
+# ENABLE_BINARY_LOCALE_GENERATION = "1"