aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/zaurus-utils
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2013-09-29 01:54:52 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-09-30 21:59:16 +0100
commit86bf074ab313fc6b37dee430f66ec88344c308cd (patch)
treee244e13dd7eae3a7dc30548cc171d935d7f77f9e /recipes-bsp/zaurus-utils
parent5854e4b25598e2c062c03f1e1eaeb32914e10962 (diff)
downloadmeta-handheld-86bf074ab313fc6b37dee430f66ec88344c308cd.tar.gz
nandlogical: move to 1.1.0 and add BBCLASSEXTEND for the klibc version
Remove nandlogical-klibc recipe Sync PV to 1.1.0 like the source tarball Remove PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes-bsp/zaurus-utils')
-rw-r--r--recipes-bsp/zaurus-utils/nandlogical-klibc_1.0.0.bb9
-rw-r--r--recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb (renamed from recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb)6
2 files changed, 5 insertions, 10 deletions
diff --git a/recipes-bsp/zaurus-utils/nandlogical-klibc_1.0.0.bb b/recipes-bsp/zaurus-utils/nandlogical-klibc_1.0.0.bb
deleted file mode 100644
index 47902d7..0000000
--- a/recipes-bsp/zaurus-utils/nandlogical-klibc_1.0.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require nandlogical_${PV}.bb
-
-inherit klibc
-
-do_compile() {
- ${CC} ${CFLAGS} ${LDFLAGS} -static -I${STAGING_INCDIR} nandlogical.c -o nandlogical
-}
-
-FILESPATH =. "${FILE_DIRNAME}/nandlogical:"
diff --git a/recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb b/recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb
index 07180c5..0fb6e2c 100644
--- a/recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb
+++ b/recipes-bsp/zaurus-utils/nandlogical_1.1.0.bb
@@ -1,7 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
+
DESCRIPTION = "Nandlogical for Sharp mtd1"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://nandlogical.c;endline=15;md5=77804e7fdf625e56869f32d9aec762a2"
-PR = "r6"
SRC_URI = "http://distro.ibiblio.org/pub/linux/distributions/pdaxrom/download/1.1.0beta4/src/survive-1.1.0.tar.bz2 \
file://oobblock-to-writesize.patch"
@@ -11,6 +12,8 @@ SRC_URI[sha256sum] = "0d02edc12509f6dc98cded37c68238f939c522cbd398fd527785a1e7e3
S = "${WORKDIR}/survive-1.1.0"
+EXTRA_OEMAKE_class-klibc = "-static -I${STAGING_INCDIR}"
+
do_compile () {
${CC} ${CFLAGS} ${LDFLAGS} nandlogical.c -o nandlogical
}
@@ -21,3 +24,4 @@ do_install () {
}
COMPATIBLE_MACHINE = "(poodle|c7x0|akita|spitz|tosa)"
+BBCLASSEXTEND = "klibc"