aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/zaurus-utils
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 16:07:21 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 16:41:50 +0100
commitb50e275329efd783a5dba9a39dcd0e54b402b127 (patch)
tree01b7f72789faf58d831380c8b032271e03e3fbf5 /recipes-bsp/zaurus-utils
parent24aecc42b91330773b32a07decbeadad138b490b (diff)
downloadmeta-handheld-b50e275329efd783a5dba9a39dcd0e54b402b127.tar.gz
zaurus-legacy-tar: inherit deploy
Integrate change from meta-zaurus to inherit deploy class for this recipe. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-bsp/zaurus-utils')
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb b/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb
index fae0520..a2c8697 100644
--- a/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb
+++ b/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb
@@ -16,8 +16,9 @@ addtask deploy before do_populate_sysroot after do_compile
COMPATIBLE_MACHINE = "spitz"
+inherit deploy
+
do_deploy() {
install -d ${DEPLOY_DIR_IMAGE}
- install -m 0755 gnu-tar ${DEPLOY_DIR_IMAGE}/gnu-tar
- package_stagefile_shell ${DEPLOY_DIR_IMAGE}/gnu-tar
+ install -m 0755 ${WORKDIR}/gnu-tar ${DEPLOY_DIR_IMAGE}/gnu-tar
}