aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-07-11 19:33:22 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-07-11 22:22:48 +0100
commit6d771d55ce3f62643b9b0a27a069c434c14fdf25 (patch)
treeadbb8f7617c4cca6ef64b412898301bec43034d7 /recipes-bsp
parent856a2bea056dfadf7885f37452cce41eb93f6662 (diff)
downloadmeta-handheld-6d771d55ce3f62643b9b0a27a069c434c14fdf25.tar.gz
formfactor: add machine-specific /etc/rotation for psplash
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/formfactor/formfactor_0.0.bbappend15
1 files changed, 14 insertions, 1 deletions
diff --git a/recipes-bsp/formfactor/formfactor_0.0.bbappend b/recipes-bsp/formfactor/formfactor_0.0.bbappend
index e406684..e888ec1 100644
--- a/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ b/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -1,4 +1,17 @@
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+do_install_prepend () {
+ # provide machine-specific /etc/rotation for psplash
+ sed -n 's/^[ \t]DISPLAY_ORIENTATION[ \t]*//p' ${S}/machconfig | tr -dc '[0-9]' > ${S}/rotation
+ printf "\n" >> ${S}/rotation
+}
+
+do_install_append () {
+ # Only install file if it has a content
+ if [ -s "${S}/rotation" ]; then
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${S}/rotation ${D}${sysconfdir}/rotation
+ fi
+}