aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto-dev.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-yocto-dev.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto-dev.bbappend16
1 files changed, 15 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-yocto-dev.bbappend b/recipes-kernel/linux/linux-yocto-dev.bbappend
index 3352291..c4e85f9 100644
--- a/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-dev:${THISDIR}/${PN}:${THISDIR}/files:"
-COMPATIBLE_MACHINE .= "|akita|c7x0|collie|h1940|poodle|spitz|tosa"
+COMPATIBLE_MACHINE .= "|akita|c7x0|collie|h1940|h3600|poodle|spitz|tosa"
# Override kernel features
#KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
@@ -9,6 +9,7 @@ KERNEL_EXTRA_FEATURES_akita ?= ""
KERNEL_EXTRA_FEATURES_c7x0 ?= ""
KERNEL_EXTRA_FEATURES_collie ?= ""
KERNEL_EXTRA_FEATURES_h1940 ?= ""
+KERNEL_EXTRA_FEATURES_h3600 ?= ""
KERNEL_EXTRA_FEATURES_poodle ?= ""
KERNEL_EXTRA_FEATURES_spitz ?= ""
KERNEL_EXTRA_FEATURES_tosa ?= ""
@@ -17,6 +18,7 @@ KMACHINE_akita = "akita"
KMACHINE_c7x0 = "c7x0"
KMACHINE_collie = "collie"
KMACHINE_h1940 = "h1940"
+KMACHINE_h3600 = "h3600"
KMACHINE_poodle = "poodle"
KMACHINE_spitz = "spitz"
KMACHINE_tosa = "tosa"
@@ -53,6 +55,18 @@ SRC_URI_append_h1940 = " \
file://qvga/logo_linux_clut224.ppm.bz2 \
"
+SRC_URI_append_h3600 = " \
+ file://defconfig \
+ file://0001-MFD-driver-for-Atmel-Microcontroller-on-iPaq-h3xxx.patch \
+ file://0002-ARM-sa1100-add-Micro-ASIC-platform-device.patch \
+ file://0003-input-driver-for-microcontroller-keys-on-the-iPaq-h3.patch \
+ file://0004-fb-backlight-add-driver-for-iPAQ-micro-backlight.patch \
+ file://0005-input-driver-for-touchscreen-on-iPaq-h3xxx.patch \
+ file://0006-leds-add-driver-for-the-iPAQ-micro.patch \
+ file://0007-power-add-driver-for-battery-reading-on-iPaq-h3xxx.patch \
+ file://qvga/logo_linux_clut224.ppm.bz2 \
+ "
+
SRC_URI_append_poodle = " \
file://feature-top.scc \
file://qvga/logo_linux_clut224.ppm.bz2 \