aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-17 07:49:56 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-17 07:51:50 -0800
commitb81abe36fca084f1eb6aaf70dfd3b5e03edb1acd (patch)
tree64eeb45276e513d0bc01bb53b29ed0edc15b9266
parent6dd2a1db71dfa79391bbe956f4d2b5cd15f30a84 (diff)
downloadmeta-openembedded-contrib-timo/python3-prettytable-ptest.tar.gz
python3-pytest-lazy-fixtures: enable ptesttimo/python3-prettytable-ptest
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb11
3 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 5985482628..321f77083e 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -37,6 +37,7 @@ PTESTS_FAST_META_PYTHON = "\
python3-pyasn1-modules \
python3-pyroute2 \
python3-pyserial \
+ python3-pytest-lazy-fixtures \
python3-pytest-mock \
python3-pytoml \
python3-pyyaml-include \
diff --git a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures/run-ptest b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb
index dcf662a2c8..4e5922af71 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb
@@ -19,3 +19,14 @@ inherit pypi python_poetry_core
PYPI_PACKAGE = "pytest_lazy_fixtures"
RDEPENDS:${PN} = "python3-pytest"
+
+inherit ptest
+
+SRC_URI += "file://run-ptest"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"