aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2019-11-01 17:34:50 +0800
committerKhem Raj <raj.khem@gmail.com>2019-11-01 17:22:53 -0700
commit92de599596f7c20ead9b9a912ef3ee700b2f691b (patch)
tree320fc548c0e2231ee5feac7837ebb20a262e256b /meta-oe/recipes-bsp/ledmon/ledmon_git.bb
parente37c095560dde568435131fa338fe3f14bd862cd (diff)
downloadmeta-openembedded-contrib-92de599596f7c20ead9b9a912ef3ee700b2f691b.tar.gz
ledmon: upgrade to 0.93
1) inherit autotools as new version use autotools. 2) Add a patch to fix compile error. 0001-Don-t-build-with-Werror-to-fix-compile-error.patch 3) Modify do_install_append() function to fix do_package error as follows: ledmon-git-r0 do_package: SYSTEMD_SERVICE_ledmon value ledmon.service does not exist 4) Add ${S}/config in CFLAGS. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp/ledmon/ledmon_git.bb')
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon_git.bb17
1 files changed, 12 insertions, 5 deletions
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
index 74ae56c671..f9ae9aad9a 100644
--- a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
+++ b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
@@ -11,15 +11,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
DEPENDS = "sg3-utils udev"
-inherit systemd
+inherit autotools systemd
SYSTEMD_SERVICE_${PN} = "ledmon.service"
+# 0.93
SRC_URI = "git://github.com/intel/ledmon;branch=master \
file://0002-include-sys-select.h-and-sys-types.h.patch \
+ file://0001-Don-t-build-with-Werror-to-fix-compile-error.patch \
"
-SRCREV = "ad1304ca1363d727425a1f23703c523e21feae4f"
+SRCREV = "1d72f9cb5c9163b2ecdf19709935720e65f5b90e"
COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
COMPATIBLE_HOST_libc-musl = "null"
@@ -27,8 +29,13 @@ COMPATIBLE_HOST_libc-musl = "null"
S = "${WORKDIR}/git"
EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
+# The ledmon sources include headers in ${S}/config to build but not in CFLAGS.
+# We need to add this include path in CFLAGS.
+CFLAGS += "-I${S}/config"
+
do_install_append() {
- install -d ${D}/${systemd_unitdir}/system
- oe_runmake DESTDIR=${D} install
- oe_runmake DESTDIR=${D}${systemd_unitdir}/system install-systemd
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0755 ${S}/systemd/ledmon.service ${D}${systemd_unitdir}/system
+ fi
}