aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2015-09-08 09:24:35 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-23 15:34:26 +0200
commit10d09386aa2dfd776c8f985c830b2758212c4629 (patch)
tree7489ac485f0e73b15f830d5d435a47890371ddd8 /meta-oe
parent18225da7505bfc5b43a700706e548bdba54e84bd (diff)
downloadmeta-openembedded-contrib-10d09386aa2dfd776c8f985c830b2758212c4629.tar.gz
acpica: update to 20150515 and fix conflicts with other layers
Meta-virtualization and meta-luv both has iasl_*.bb, which is a subset of this recipe. Extend this recipe to provide the native tools and add the necessary runtime conflict options. Also address style issues by moving around a few bits and adding some whitespace. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/acpica/acpica_20150515.bb (renamed from meta-oe/recipes-extended/acpica/acpica_20140828.bb)18
1 files changed, 15 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/acpica/acpica_20140828.bb b/meta-oe/recipes-extended/acpica/acpica_20150515.bb
index fb19c8858a..de897e1917 100644
--- a/meta-oe/recipes-extended/acpica/acpica_20140828.bb
+++ b/meta-oe/recipes-extended/acpica/acpica_20150515.bb
@@ -5,17 +5,22 @@ Power Interface Specification (ACPI). ACPICA code contains those portions of \
ACPI meant to be directly integrated into the host OS as a kernel-resident \
subsystem, and a small set of tools to assist in developing and debugging \
ACPI tables."
+
HOMEPAGE = "http://www.acpica.org/"
SECTION = "console/tools"
+
LICENSE = "BSD | GPLv2"
LIC_FILES_CHKSUM = "file://generate/unix/readme.txt;md5=204407e197c1a01154a48f6c6280c3aa"
+
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
+
DEPENDS = "bison flex"
SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \
file://no-werror.patch \
"
-SRC_URI[md5sum] = "6f05f0d10166a1b1ff6107f3d1cdf1e5"
-SRC_URI[sha256sum] = "01d8867656c5ba41dec307c4383ce676196ad4281ac2c9dec9f5be5fac6d888e"
+SRC_URI[md5sum] = "2bc4a7ccc82de9df9fa964f784ecb29c"
+SRC_URI[sha256sum] = "61204ec56d71bc9bfa2ee2ade4c66f7e8541772ac72ef8ccc20b3f339cc96374"
S = "${WORKDIR}/acpica-unix2-${PV}"
@@ -31,4 +36,11 @@ do_install() {
install -D -p -m0755 generate/unix/bin*/acpixtract ${D}${bindir}/acpixtract
}
-COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
+# iasl*.bb is a subset of this recipe, so RREPLACE it
+PROVIDES = "iasl"
+RPROVIDES_${PN} += "iasl"
+RREPLACES_${PN} += "iasl"
+RCONFLIGHTS_${PN} += "iasl"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"