aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-02-15 01:04:45 -0500
committerKhem Raj <raj.khem@gmail.com>2019-02-17 12:21:26 -0800
commitce02a140a0214c6cace3de3e1f1e3ed943b0655a (patch)
treea1bcf1f5721aa2e0bef3fd9bba6aa75939d3297d /meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb
parentcb1b5130441b79473fde4083c07ac5d18dd28561 (diff)
downloadmeta-openembedded-contrib-ce02a140a0214c6cace3de3e1f1e3ed943b0655a.tar.gz
python3-protobuf: add cpp implementation support
- Compiling with option `--cpp_implementation', add cpp implementation support which requires to build with protobuf. - Workaround native compile failure while host gcc <= 4.8 Setting environment KOKORO_BUILD_NUMBER, the build will explicitly compile with option `-std=c++11', it could workaround native compile failure while host gcc <= 4.8 ... /usr/include/c++/4.8/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options ... - Add Python 3.7 compatibility Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb b/meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb
index 781d1dc4da..9b0668a02b 100644
--- a/meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb
+++ b/meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb
@@ -1,2 +1,11 @@
inherit setuptools3
require python-protobuf.inc
+
+SRC_URI += "file://0001-Add-Python-3.7-compatibility-4862.patch"
+DEPENDS += "protobuf"
+DISTUTILS_BUILD_ARGS += "--cpp_implementation"
+DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
+
+do_compile_prepend_class-native () {
+ export KOKORO_BUILD_NUMBER="1"
+}