aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-07-24 13:58:25 -0400
committerKhem Raj <raj.khem@gmail.com>2023-07-24 20:24:26 -0700
commit0eb4abcafd6aa0130533b3ea93125d636b8293bb (patch)
treedccb0201f04467859c702df6df5394a74f4574e8 /meta-python/recipes-devtools
parent56d5b088e1dba5a12de357437f4e93946343a7f7 (diff)
downloadmeta-openembedded-contrib-0eb4abcafd6aa0130533b3ea93125d636b8293bb.tar.gz
python3-versioneer: add recipe
This module is required by newer versions of pandas, so add it as a recipe. Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-versioneer_0.29.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-versioneer_0.29.bb b/meta-python/recipes-devtools/python/python3-versioneer_0.29.bb
new file mode 100644
index 0000000000..bdfbfd1be1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-versioneer_0.29.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Easy VCS-based management of project version strings"
+HOMEPAGE = "https://github.com/python-versioneer/python-versioneer"
+SECTION = "devel/python"
+
+LICENSE = "Unlicense"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f4c62131f879a8445e16a7f265aea635"
+
+SRC_URI[sha256sum] = "5ab283b9857211d61b53318b7c792cf68e798e765ee17c27ade9f6c924235731"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} += "\
+ python3-json \
+ python3-netclient \
+ python3-tomllib \
+"
+
+BBCLASSEXTEND = "native nativesdk"