aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-07-25 15:09:40 -0400
committerKhem Raj <raj.khem@gmail.com>2023-07-25 12:46:19 -0700
commit3a63fbf62a72cbfb407f776f673ca34e43f08b9a (patch)
tree4bff432a5e7042eab1b18fcc5771a4fb02be6de8 /meta-python/recipes-devtools
parentfe48529f1c763ffaea6835837da41421c9a18ee1 (diff)
downloadmeta-openembedded-contrib-3a63fbf62a72cbfb407f776f673ca34e43f08b9a.tar.gz
python3-matplotlib: upgrade 3.6.3 -> 3.7.2
- Adjust target lines in setup.py for LIC_FILES_CHKSUM, since the content of interest has moved (but not changed) - Tweak matplotlib-disable-download.patch to apply on 3.7.2 - Remove backported patch since it's in 3.7.2: [tgamblin@megalith matplotlib]$ git log --oneline --grep="removed RandomNumberGenerator class" 601d92a885 removed RandomNumberGenerator class, included <random>, replaced random_shuffle with shuffle and used mersenne twister engine to generate uniform random bit generator for the shuffle. [tgamblin@megalith matplotlib]$ git tag --contains 601d92a885 v3.7.0 v3.7.0rc1 v3.7.1 v3.7.2 Changelog: https://github.com/matplotlib/matplotlib/releases Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch59
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch28
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.7.2.bb (renamed from meta-python/recipes-devtools/python/python3-matplotlib_3.6.3.bb)7
3 files changed, 18 insertions, 76 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch b/meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch
deleted file mode 100644
index 1f9b8cdeaf..0000000000
--- a/meta-python/recipes-devtools/python/python3-matplotlib/0001-removed-RandomNumberGenerator-class-included-random-.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 3eb9987b02cc10b93e09219ddc86aa6be5f10177 Mon Sep 17 00:00:00 2001
-From: tybeller <ty.c.beller@gmail.com>
-Date: Fri, 30 Sep 2022 16:13:41 -0400
-Subject: [PATCH] removed RandomNumberGenerator class, included <random>,
- replaced random_shuffle with shuffle and used mersenne twister engine to
- generate uniform random bit generator for the shuffle.
-
-Upstream-Status: Backport [https://github.com/matplotlib/matplotlib/commit/601d92a8850]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/tri/_tri.cpp | 20 ++++----------------
- 1 file changed, 4 insertions(+), 16 deletions(-)
-
-diff --git a/src/tri/_tri.cpp b/src/tri/_tri.cpp
-index b7a87783de..6e639eea44 100644
---- a/src/tri/_tri.cpp
-+++ b/src/tri/_tri.cpp
-@@ -12,6 +12,7 @@
-
- #include <algorithm>
- #include <set>
-+#include <random>
-
-
- TriEdge::TriEdge()
-@@ -1465,8 +1466,8 @@ TrapezoidMapTriFinder::initialize()
- _tree->assert_valid(false);
-
- // Randomly shuffle all edges other than first 2.
-- RandomNumberGenerator rng(1234);
-- std::random_shuffle(_edges.begin()+2, _edges.end(), rng);
-+ std::mt19937 rng(1234);
-+ std::shuffle(_edges.begin()+2, _edges.end(), rng);
-
- // Add edges, one at a time, to tree.
- size_t nedges = _edges.size();
-@@ -2055,17 +2056,4 @@ TrapezoidMapTriFinder::Trapezoid::set_upper_right(Trapezoid* upper_right_)
- upper_right = upper_right_;
- if (upper_right != 0)
- upper_right->upper_left = this;
--}
--
--
--
--RandomNumberGenerator::RandomNumberGenerator(unsigned long seed)
-- : _m(21870), _a(1291), _c(4621), _seed(seed % _m)
--{}
--
--unsigned long
--RandomNumberGenerator::operator()(unsigned long max_value)
--{
-- _seed = (_seed*_a + _c) % _m;
-- return (_seed*max_value) / _m;
--}
-+}
-\ No newline at end of file
---
-2.39.0
-
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
index 899cac624a..aea8f62ea7 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
+++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
@@ -4,19 +4,17 @@ Upstream-Status: Inappropriate [disable feature]
Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
+Update patch to fit on 3.7.2.
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
+
+diff --git a/setup.py b/setup.py
+index 0bea13fa6f..f39d8fc871 100644
--- a/setup.py
+++ b/setup.py
-@@ -303,7 +303,6 @@ setup( # Finally, pass this all along t
- setup_requires=[
- "certifi>=2020.06.20",
- "numpy>=1.19",
-- "setuptools_scm>=7",
- ],
- install_requires=[
- "contourpy>=1.0.1",
-@@ -315,13 +314,7 @@ setup( # Finally, pass this all along t
+@@ -327,13 +327,7 @@ setup( # Finally, pass this all along to setuptools to do the heavy lifting.
"pillow>=6.2.0",
- "pyparsing>=2.2.1",
+ "pyparsing>=2.3.1,<3.1",
"python-dateutil>=2.7",
- ] + (
- # Installing from a git checkout that is not producing a wheel.
@@ -26,12 +24,14 @@ Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
- ) else []
- ),
+ ],
- use_scm_version={
- "version_scheme": "release-branch-semver",
- "local_scheme": "node-and-date",
+ extras_require={
+ ':python_version<"3.10"': [
+ "importlib-resources>=3.2.0",
+diff --git a/setupext.py b/setupext.py
+index a898d642d6..474172ff8f 100644
--- a/setupext.py
+++ b/setupext.py
-@@ -65,40 +65,7 @@ def get_from_cache_or_download(url, sha)
+@@ -66,40 +66,7 @@ def get_from_cache_or_download(url, sha):
BytesIO
The file loaded into memory.
"""
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.6.3.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.7.2.bb
index fa0a78d6a9..72c369100a 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.6.3.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.7.2.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "https://github.com/matplotlib/matplotlib"
SECTION = "devel/python"
LICENSE = "PSF-2.0"
LIC_FILES_CHKSUM = "\
- file://setup.py;beginline=283;endline=283;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \
+ file://setup.py;beginline=293;endline=293;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \
file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
"
@@ -20,15 +20,16 @@ DEPENDS = "\
python3-pytz-native \
python3-certifi-native \
python3-setuptools-scm-native \
+ python3-pybind11-native \
"
-SRC_URI[sha256sum] = "1f4d69707b1677560cd952544ee4962f68ff07952fb9069ff8c12b56353cb8c9"
+SRC_URI[sha256sum] = "a8cdb91dddb04436bd2f098b8fdf4b81352e68cf4d2c6756fcc414791076569b"
inherit pypi setuptools3 pkgconfig
# Stop the component from attempting to download when it detects a missing
# dependency
SRC_URI += "file://matplotlib-disable-download.patch \
- file://0001-removed-RandomNumberGenerator-class-included-random-.patch"
+"
# This python module requires a full copy of freetype-2.6.1
SRC_URI += "https://downloads.sourceforge.net/project/freetype/freetype2/2.6.1/freetype-2.6.1.tar.gz;name=freetype;subdir=matplotlib-${PV}/build"