aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python-matplotlib_1.1.0.bb
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-15 15:42:55 -0700
committerTim Orling <TicoTimo@gmail.com>2014-07-15 15:42:55 -0700
commita6acceb1dc1d391e20c3722e685aa7c9cca313b3 (patch)
treec31a773a177c030ed638252f99755c9be8ec9c12 /meta-python/recipes-python/python-matplotlib_1.1.0.bb
parentdf9ed3b72b1920938e4c79c20cdd288a1d7b16a8 (diff)
downloadmeta-openembedded-contrib-timo/meta-python.tar.gz
meta-python: move recipes from meta-oetimo/meta-python
* Move recipes from meta-openembedded/meta-oe that are not depended upon by recipes already in meta-oe (e.g. gateone, anki) * Recipes NOT moved: python-futures python-pyopenssl python-simplejson python-tornado python-pyqt python-sip Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python-matplotlib_1.1.0.bb')
-rw-r--r--meta-python/recipes-python/python-matplotlib_1.1.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python-matplotlib_1.1.0.bb b/meta-python/recipes-python/python-matplotlib_1.1.0.bb
new file mode 100644
index 0000000000..7bb61fd57e
--- /dev/null
+++ b/meta-python/recipes-python/python-matplotlib_1.1.0.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "matplotlib is a python 2D plotting library which produces publication quality figures in a variety of hardcopy formats"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://README.txt;md5=83c5bf8b16a5f99507f2f47a21ae3b81"
+PR = "r1"
+
+DEPENDS += "python-numpy freetype libpng"
+RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/matplotlib/matplotlib-${PV}.tar.gz \
+ file://fix_setup.patch \
+ file://fix_setupext.patch \
+"
+
+S = "${WORKDIR}/matplotlib-${PV}"
+
+EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
+
+inherit distutils
+
+do_compile_prepend() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
+ true
+}
+
+# need to export these variables for python-config to work
+export PYTHONPATH
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+
+SRC_URI[md5sum] = "57a627f30b3b27821f808659889514c2"
+SRC_URI[sha256sum] = "be37e1d86c65ecacae6683f8805e051e9904e5f2e02bf2b7a34262c46a6d06a7"