aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python-pyusb_1.0.0a2.bb
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-15 15:42:55 -0700
committerTim Orling <TicoTimo@gmail.com>2014-07-15 15:42:55 -0700
commita6acceb1dc1d391e20c3722e685aa7c9cca313b3 (patch)
treec31a773a177c030ed638252f99755c9be8ec9c12 /meta-python/recipes-python/python-pyusb_1.0.0a2.bb
parentdf9ed3b72b1920938e4c79c20cdd288a1d7b16a8 (diff)
downloadmeta-openembedded-contrib-timo/meta-python.tar.gz
meta-python: move recipes from meta-oetimo/meta-python
* Move recipes from meta-openembedded/meta-oe that are not depended upon by recipes already in meta-oe (e.g. gateone, anki) * Recipes NOT moved: python-futures python-pyopenssl python-simplejson python-tornado python-pyqt python-sip Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python-pyusb_1.0.0a2.bb')
-rw-r--r--meta-python/recipes-python/python-pyusb_1.0.0a2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python-pyusb_1.0.0a2.bb b/meta-python/recipes-python/python-pyusb_1.0.0a2.bb
new file mode 100644
index 0000000000..360f213221
--- /dev/null
+++ b/meta-python/recipes-python/python-pyusb_1.0.0a2.bb
@@ -0,0 +1,18 @@
+SUMMARY = "PyUSB provides USB access on the Python language"
+HOMEPAGE = "http://pyusb.sourceforge.net/"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a53a9c39efcfb812e2464af14afab013"
+DEPENDS = "libusb1"
+PR = "r1"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/pyusb/${SRCNAME}-${PV}.tar.gz \
+"
+SRC_URI[md5sum] = "9136b3dc019272c62a5b6d4eb624f89f"
+SRC_URI[sha256sum] = "dacbf7d568c0bb09a974d56da66d165351f1ba3c4d5169ab5b734266623e1736"
+
+SRCNAME = "pyusb"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils