aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ruby/recipes-devtools/ruby/ruby.inc
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-10-16 08:34:41 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-26 14:09:56 +0100
commitd04b996ec223465729920ec3599b53dabb3ceb05 (patch)
treec4d82d0bbaa01bd41e934a2177803d87b3778d18 /meta-ruby/recipes-devtools/ruby/ruby.inc
parenta1e6087f092e09d85928440ba86857061abcc65b (diff)
downloadmeta-openembedded-contrib-d04b996ec223465729920ec3599b53dabb3ceb05.tar.gz
ruby: Add from OE-Classic
* No modifications in this commit * MJ: PR reset, PRIORITY dropped, LICENSE fix, LIC_FILES_CHKSUMs added Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-ruby/recipes-devtools/ruby/ruby.inc')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby.inc38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby.inc b/meta-ruby/recipes-devtools/ruby/ruby.inc
new file mode 100644
index 0000000000..a70f951518
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/ruby.inc
@@ -0,0 +1,38 @@
+DESCRIPTION = "Ruby is an interpreted scripting language \
+for quick and easy object-oriented programming."
+SECTION = "devel/ruby"
+LICENSE = "GPLv2 & LGPLv2+ & BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=99f88e67b65504d289a0326c59f9c148 \
+ file://LEGAL;md5=7d502ae3b621dc406b220dadddb72e16 \
+ file://LGPL;md5=7fbc338309ac38fefcd64b04bb903e34 \
+"
+
+DEPENDS = "ruby-native zlib openssl"
+DEPENDS_virtclass-native = ""
+
+INC_PR = "r0"
+
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
+ file://extmk_run.patch \
+ file://extmk.patch \
+"
+
+S = "${WORKDIR}/ruby-${PV}"
+
+inherit autotools
+
+# fix building of socket extension
+EXTRA_OECONF = "--enable-wide-getaddrinfo"
+
+# This snippet lets compiled extensions which rely on external libraries,
+# such as zlib, compile properly. If we don't do this, then when extmk.rb
+# runs, it uses the native libraries instead of the target libraries, and so
+# none of the linking operations succeed -- which makes extconf.rb think
+# that the libraries aren't available and hence that the extension can't be
+# built.
+
+do_configure_prepend() {
+ sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
+ rm -rf ${S}/ruby/
+}