aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-12-27 23:42:16 +0800
committerKhem Raj <raj.khem@gmail.com>2022-12-27 16:03:06 -0800
commit96dc7e791399ed8714fb312514f18eedaa32334b (patch)
tree6e253f8c468971d999177cdce0bddf10b233e3c0 /meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
parent274883d9838a10965923e81c8007b09c614d85ed (diff)
downloadmeta-openembedded-contrib-96dc7e791399ed8714fb312514f18eedaa32334b.tar.gz
xfce4-sensors-plugin: 1.4.3 -> 1.4.4
Update xfce4-sensors-plugin from 1.4.3 to 1.4.4 * update license with GPL-2.0-or-later Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb')
-rw-r--r--meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
new file mode 100644
index 0000000000..69996d2a3f
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Sensors plugin for the Xfce Panel"
+HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+inherit xfce-panel-plugin
+
+SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch"
+SRC_URI[sha256sum] = "6c1605a738e5df40e084d08ac93f962cd445093396de1e9bfadc7ab4588c36b6"
+
+EXTRA_OECONF = " \
+ --disable-procacpi \
+ --disable-xnvctrl \
+"
+
+do_configure:prepend() {
+ sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
+}
+
+PACKAGECONFIG ??= "libnotify"
+PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
+PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
+PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"
+PACKAGECONFIG[libnotify] = "--enable-notification,--disable-notification, libnotify"
+
+FILES_SOLIBSDEV = "${libdir}/xfce4/modules/lib*${SOLIBSDEV}"