aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-06-12 11:39:02 -0700
committerKhem Raj <raj.khem@gmail.com>2023-06-12 11:43:30 -0700
commit1ae57e285bbea4be178fb3428fe55a958a6d1d92 (patch)
treef52dd9403da9a660bfa3095535d3ca9ee80cad1c /meta-xfce
parentb802655e13091ee9658c615e605f3954706091f5 (diff)
downloadmeta-openembedded-contrib-1ae57e285bbea4be178fb3428fe55a958a6d1d92.tar.gz
xfce4-sensors-plugin: Use bfd linker instead of lld
lld linking fails | aarch64-yoe-linux-ld.lld: error: undefined symbol: gtk_sensorstacho_new(GtkOrientation, unsigned int, SensorsTachoStyle) | >>> referenced by actions.cc:143 (/usr/src/debug/xfce4-sensors-plugin/1.4.4-r0/src/../../xfce4-sensors-plugin-1.4.4/src/actions.cc:143) | >>> xfce4_sensors-actions.o:(refresh_tacho_view(xfce4::Ptr<t_sensors_dialog> const&)) | | aarch64-yoe-linux-ld.lld: error: undefined symbol: gtk_sensorstacho_set_color(_GtkSensorsTacho*, char const*) | >>> referenced by actions.cc:146 (/usr/src/debug/xfce4-sensors-plugin/1.4.4-r0/src/../../xfce4-sensors-plugin-1.4.4/src/actions.cc:146) | >>> xfce4_sensors-actions.o:(refresh_tacho_view(xfce4::Ptr<t_sensors_dialog> const&)) | >>> referenced by callbacks.cc:197 (/usr/src/debug/xfce4-sensors-plugin/1.4.4-r0/src/../../xfce4-sensors-plugin-1.4.4/src/callbacks.cc:197) | >>> xfce4_sensors-callbacks.o:(list_cell_color_edited_(_GtkCellRendererText*, char const*, char const*, xfce4::Ptr<t_sensors_dialog> const&)) | Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
index 69996d2a3f..eb1165c578 100644
--- a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
+++ b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
@@ -13,6 +13,8 @@ EXTRA_OECONF = " \
--disable-xnvctrl \
"
+LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' -fuse-ld=bfd', '', d)}"
+
do_configure:prepend() {
sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
}