aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support/mysql/files/configure-ps-cache-check.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-03 11:44:38 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-03 12:02:34 +0100
commitef3de09a6bec187e1b6b8db46c55a237ba226a2c (patch)
tree5f843e4bfe14f8334eeb2bc1be7eeb348d49b0b6 /recipes-support/mysql/files/configure-ps-cache-check.patch
parent156f6d3dc264c26f743a4359e4d40181a79ba038 (diff)
downloadmeta-openembedded-contrib-ef3de09a6bec187e1b6b8db46c55a237ba226a2c.tar.gz
mysql5: import from OE
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-support/mysql/files/configure-ps-cache-check.patch')
-rw-r--r--recipes-support/mysql/files/configure-ps-cache-check.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-support/mysql/files/configure-ps-cache-check.patch b/recipes-support/mysql/files/configure-ps-cache-check.patch
new file mode 100644
index 0000000000..3b5b3fd063
--- /dev/null
+++ b/recipes-support/mysql/files/configure-ps-cache-check.patch
@@ -0,0 +1,27 @@
+Index: mysql-4.1.22/configure.in
+===================================================================
+--- mysql-4.1.22.orig/configure.in 2009-01-28 16:33:28.000000000 +0000
++++ mysql-4.1.22/configure.in 2009-01-28 16:43:26.000000000 +0000
+@@ -471,8 +471,8 @@
+
+ # Lock for PS
+ AC_PATH_PROG(PS, ps, ps)
+-AC_MSG_CHECKING("how to check if pid exists")
+-PS=$ac_cv_path_PS
++AC_CACHE_CHECK([how to check if pid exists], [ac_cv_FIND_PROC],
++[
+ # Linux style
+ if $PS p $$ 2> /dev/null | grep $0 > /dev/null
+ then
+@@ -511,8 +511,9 @@
+ AC_MSG_ERROR([Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual.])
+ esac
+ fi
+-AC_SUBST(FIND_PROC)
+-AC_MSG_RESULT("$FIND_PROC")
++ac_cv_FIND_PROC="$FIND_PROC"
++])
++AC_SUBST([FIND_PROC], [$ac_cv_FIND_PROC])
+
+ # Check if a pid is valid
+ AC_PATH_PROG(KILL, kill, kill)