aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-utils
diff options
context:
space:
mode:
authorSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2019-02-06 11:37:23 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-07 09:15:42 -0800
commitc245374fafbc4769e0c98ae18ac9ff71f9f14169 (patch)
treeb323d0b182de3e9e89e14972432bcc90651891b6 /recipes-utils
parent7baf5c36360bb628f4421095b958225c7e6ab487 (diff)
downloadmeta-openembedded-contrib-c245374fafbc4769e0c98ae18ac9ff71f9f14169.tar.gz
ace-cloud-editor_git.bb: Add recipe for ace cloud editor
Yocto recipe for Ace-code-editor an open source embeddable code editor written in JavaScript. It can be easily embedded in any webpage and JavaScript application. Signed-off-by: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com> Signed-off-by: Bhargava Sreekantappa Gayathri <bhargava.sreekantappa-gayathri@xilinx.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-utils')
-rw-r--r--recipes-utils/ace-cloud-editor/ace-cloud-editor_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-utils/ace-cloud-editor/ace-cloud-editor_git.bb b/recipes-utils/ace-cloud-editor/ace-cloud-editor_git.bb
new file mode 100644
index 0000000000..4ea6c8a295
--- /dev/null
+++ b/recipes-utils/ace-cloud-editor/ace-cloud-editor_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Ace is a code editor written in JavaScript."
+SUMMARY = "Ace is a code editor written in JavaScript. This repository has only generated files"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=794d11c5219c59c9efa2487c2b4066b2"
+
+SRC_URI = "git://github.com/ajaxorg/ace-builds.git;protocol=https"
+
+PV = "02.07.17+git${SRCPV}"
+SRCREV = "812e2c56aed246931a667f16c28b096e34597016"
+
+FILES_${PN} = "${datadir}/ace-builds"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "rsync-native"
+
+do_install () {
+ install -d ${D}/${datadir}/ace-builds/src-noconflict
+ rsync -r --exclude=".*" ${S}/src-noconflict/* ${D}/${datadir}/ace-builds/src-noconflict
+}
+