aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service (renamed from meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service)0
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb16
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend18
3 files changed, 13 insertions, 21 deletions
diff --git a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
index a2d703185d..a2d703185d 100644
--- a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
index 84d6dce32d..422ebdab40 100644
--- a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
@@ -5,16 +5,18 @@ SECTION = "network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r6"
+PR = "r9"
DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar.gz \
- file://cherokee.init"
+ file://cherokee.init \
+ file://cherokee.service \
+"
SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"
-inherit autotools pkgconfig binconfig update-rc.d
+inherit autotools pkgconfig binconfig update-rc.d systemd
EXTRA_OECONF = "--disable-static \
--disable-nls \
@@ -27,6 +29,9 @@ do_install_append () {
# clean up .la files for plugins
rm -f ${D}${libdir}/cherokee/*.la
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system
}
# Put -dev near the front so we can move the .la files into it with a wildcard
@@ -44,3 +49,8 @@ CONFFILES_${PN} = " \
INITSCRIPT_NAME = "cherokee"
INITSCRIPT_PARAMS = "defaults 91 91"
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "cherokee.service"
diff --git a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend
deleted file mode 100644
index b792c621bc..0000000000
--- a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-PRINC := "${@int(PRINC) + 2}"
-
-inherit systemd
-
-SRC_URI += "file://cherokee.service"
-
-RPROVIDES_${PN} += "${PN}-systemd"
-RREPLACES_${PN} += "${PN}-systemd"
-RCONFLICTS_${PN} += "${PN}-systemd"
-SYSTEMD_SERVICE_${PN} = "cherokee.service"
-
-do_install_append() {
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system
-}
-