aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb')
-rw-r--r--meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb b/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb
index 8c44a3e5c4..0c8c5d852e 100644
--- a/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb
+++ b/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb
@@ -8,12 +8,18 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=8c2bc283e65df398ced5f5b747e78162"
DEPENDS = "libconfig libnl"
SRCREV = "48a5f38778b18d6659a672ccb4640f25c6720827"
-SRC_URI = "git://github.com/jrfastab/lldpad.git;protocol=http"
+SRC_URI = "git://github.com/jrfastab/lldpad.git;protocol=http \
+ file://0001-get-inline-functions-work-with-both-gnu11-and-gnu89.patch \
+"
S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig systemd
+do_configure_prepend() {
+ sed -i "s:-Werror::g" ${S}/Makefile.am
+}
+
do_install_append () {
install -m 0755 -d ${D}${systemd_unitdir}
mv ${D}${prefix}${systemd_unitdir}/* ${D}${systemd_unitdir}/