aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-eth-account_0.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-eth-account_0.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-account_0.9.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-eth-account_0.9.0.bb b/meta-python/recipes-devtools/python/python3-eth-account_0.9.0.bb
new file mode 100644
index 0000000000..e33b7679c9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-account_0.9.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Assign Ethereum transactions and messages with local private keys."
+HOMEPAGE = "https://github.com/ethereum/eth-account"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16ffc86adf4293d4cfb204e77d62cfe6"
+
+SRC_URI[sha256sum] = "5f66ecb7bc52569924dfaf4a9add501b1c2a4901eec74e3c0598cd26d0971777"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-bitarray \
+ python3-cytoolz \
+ python3-eth-abi \
+ python3-eth-keyfile \
+ python3-eth-rlp \
+ python3-hexbytes \
+"