aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-12-21 08:06:03 +0800
committerKhem Raj <raj.khem@gmail.com>2021-12-21 18:49:37 -0800
commit0f5d1070994b7f76d7ea88569c787caea5d2e49c (patch)
treefe266d8044a4dd6cb24e65cae582d58648d5c177
parent60637824d8b4d4a319a4384e29eb0a1344ddc634 (diff)
downloadmeta-openembedded-0f5d1070994b7f76d7ea88569c787caea5d2e49c.tar.gz
chrony: upgrade 4.1 -> 4.2
refresh arm_eabi.patch Changelog: ========== Enhancements -Add support for NTPv4 extension field improving synchronisation stability and resolution of root delay and dispersion (experimental) -Add support for NTP over PTP (experimental) -Add support for AES-CMAC and hash functions in GnuTLS -Improve server interleaved mode to be more reliable and support multiple clients behind NAT -Update seccomp filter -Add statistics about interleaved mode to serverstats report Bug fixes -Fix RTC support with 64-bit time_t on 32-bit Linux -Fix seccomp filter to work correctly with bind*device directives -Suppress kernel adjustments of system clock (dosynctodr) on illumos Other changes -Switch Solaris support to illumos Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/chrony/chrony/arm_eabi.patch30
-rw-r--r--meta-networking/recipes-support/chrony/chrony_4.2.bb (renamed from meta-networking/recipes-support/chrony/chrony_4.1.bb)2
2 files changed, 19 insertions, 13 deletions
diff --git a/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch b/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch
index 837cb6d72c..4a2769b843 100644
--- a/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch
+++ b/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch
@@ -23,19 +23,22 @@ Subject: [PATCH] chrony: fix build failure for arma9
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
- sys_linux.c | 20 ++++++++++++++------
- 1 file changed, 14 insertions(+), 6 deletions(-)
+ sys_linux.c | 15 +++++++++------
+ 1 file changed, 9 insertions(+), 6 deletions(-)
+diff --git a/sys_linux.c b/sys_linux.c
+index 9cab2ef..8104b8f 100644
--- a/sys_linux.c
+++ b/sys_linux.c
-@@ -499,14 +499,12 @@ SYS_Linux_EnableSystemCallFilter(int lev
+@@ -484,7 +484,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context)
#endif
SCMP_SYS(gettimeofday),
SCMP_SYS(settimeofday),
- SCMP_SYS(time),
-
+
/* Process */
SCMP_SYS(clone),
+@@ -494,7 +493,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context)
SCMP_SYS(exit),
SCMP_SYS(exit_group),
SCMP_SYS(getpid),
@@ -43,7 +46,7 @@ Subject: [PATCH] chrony: fix build failure for arma9
SCMP_SYS(getuid),
SCMP_SYS(getuid32),
SCMP_SYS(rt_sigaction),
-@@ -520,7 +518,6 @@ SYS_Linux_EnableSystemCallFilter(int lev
+@@ -508,7 +506,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context)
/* Memory */
SCMP_SYS(brk),
SCMP_SYS(madvise),
@@ -51,28 +54,28 @@ Subject: [PATCH] chrony: fix build failure for arma9
SCMP_SYS(mmap2),
SCMP_SYS(mprotect),
SCMP_SYS(mremap),
-@@ -580,8 +577,6 @@ SYS_Linux_EnableSystemCallFilter(int lev
+@@ -568,8 +565,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context)
SCMP_SYS(sendmsg),
SCMP_SYS(sendto),
SCMP_SYS(shutdown),
- /* TODO: check socketcall arguments */
- SCMP_SYS(socketcall),
-
+
/* General I/O */
SCMP_SYS(_newselect),
-@@ -604,7 +599,6 @@ SYS_Linux_EnableSystemCallFilter(int lev
+@@ -593,7 +588,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context)
#ifdef __NR_futex_time64
SCMP_SYS(futex_time64),
#endif
- SCMP_SYS(select),
SCMP_SYS(set_robust_list),
SCMP_SYS(write),
-
-@@ -612,6 +606,15 @@ SYS_Linux_EnableSystemCallFilter(int lev
+
+@@ -601,6 +595,15 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context)
SCMP_SYS(getrandom),
SCMP_SYS(sysinfo),
SCMP_SYS(uname),
-+ /* not always available */
++ /* not always available */
+#if ! defined(__ARM_EABI__)
+ SCMP_SYS(time),
+ SCMP_SYS(getrlimit),
@@ -82,5 +85,8 @@ Subject: [PATCH] chrony: fix build failure for arma9
+ SCMP_SYS(socketcall),
+#endif
};
-
+
const int denied_any[] = {
+--
+2.25.1
+
diff --git a/meta-networking/recipes-support/chrony/chrony_4.1.bb b/meta-networking/recipes-support/chrony/chrony_4.2.bb
index 117451db2e..609aaab880 100644
--- a/meta-networking/recipes-support/chrony/chrony_4.1.bb
+++ b/meta-networking/recipes-support/chrony/chrony_4.2.bb
@@ -39,7 +39,7 @@ SRC_URI = "https://download.tuxfamily.org/chrony/chrony-${PV}.tar.gz \
SRC_URI:append:libc-musl = " \
file://0001-Fix-compilation-with-musl.patch \
"
-SRC_URI[sha256sum] = "ed76f2d3f9347ac6221a91ad4bd553dd0565ac188cd7490d0801d08f7171164c"
+SRC_URI[sha256sum] = "273f9fd15c328ed6f3a5f6ba6baec35a421a34a73bb725605329b1712048db9a"
DEPENDS = "pps-tools"