aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2022-04-09 16:54:39 +0800
committerTrevor Gamblin <trevor.gamblin@windriver.com>2022-04-11 09:22:30 -0400
commit46612115db600abf90eb5cf35b3cf10be1e2f5ac (patch)
tree5db2d660e4b39bc40c1c06c0aceeef36fc92833f
parentb924bc52ca64da65456e8c7f45fdaa1b4dda4ac3 (diff)
downloadmeta-openembedded-46612115db600abf90eb5cf35b3cf10be1e2f5ac.tar.gz
python3-wxgtk4: Require DISTRO_FEATURES as gtk3
It can't be built without gtk3: No package 'gtk+-3.0' found So make it have the same DISTRO_FEATURES as gtk3. It may also support gtk2, but it depends on wxwidgets which doesn't support gtk2, so we don't have to consider that. And python3-wxgtk4 doesn't have PACKAGECONFIG, so remove the checking for PACKAGECONFIG. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
index 423d3bdae7..3583acc9cd 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
@@ -4,10 +4,6 @@ HOMEPAGE = "http://www.wxpython.org"
LICENSE = "WXwindows"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce1d18e2d633d41786c0a8dfbc80917"
-inherit features_check
-
-REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'no_gui', '', 'x11', d)}"
-
DEPENDS = "wxwidgets-native wxwidgets"
PYPI_PACKAGE = "wxPython"
@@ -20,7 +16,9 @@ SRC_URI[sha256sum] = "00e5e3180ac7f2852f342ad341d57c44e7e4326de0b550b9a5c4a8361b
S = "${WORKDIR}/wxPython-${PV}"
-inherit pypi setuptools3 pkgconfig
+inherit pypi setuptools3 pkgconfig features_check
+
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR} --baselib=${baselib}'"