aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-19 11:10:10 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-22 08:38:08 -0700
commit502048818daa8bc755db6213b677c83636ba569b (patch)
tree924812a4e240d32a8f7dbbcac870583e98ac06c6
parent1ac66c0dd74febf52e1a34041a9a0b06374abee5 (diff)
downloadmeta-openembedded-502048818daa8bc755db6213b677c83636ba569b.tar.gz
python3-prompt-toolkit: Upgrade 2.0.10 -> 3.0.5
Upgrade to release 3.0.5 and add HOMEPAGE. The new release brings: New features: - (almost) 100% type annotated. - Native asyncio instead of custom event loops. - Added shift-based text selection. - Added many more vt100 ANSI sequences and keys. - Improved control/shift key support in Windows. - No Mypy errors in prompt_toolkit anymore. - Added `set_exception_handler` optional argument to `PromptSession.prompt()`. Breaking changes: - Python 2 support has been dropped. Minimal Python version is now 3.6, although 3.7 is preferred (because of ContextVars). - Native asyncio, so some async code becomes slightly different. - The active `Application` became a contextvar. Which means that it should be propagated correctly to the code that requires it. However, random other threads or coroutines won't be able to know what the current application is. - The dialog shortcuts API changed. All dialog functions now return an `Application`. You still have to call either `run()` or `run_async` on the `Application` object. - The way inputhooks work is changed. - `patch_stdout` now requires an `Application` as input. - `ShiftControl` has been replaced with `ControlShift` and `s-c` with `c-s` in key bindings. Aliases for backwards-compatibility have been added. Fixes: - Bugfix in invalidate code. `PromptSession` was invalidating the UI continuously. - Add uvloop support. - Forwarded `set_exception_handler` in `Application.run` to the `run_async` call. - Bugfix in `NestedCompleter` when there is a leading space. - Bugfix in mouse handling on Windows. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb (renamed from meta-python/recipes-devtools/python/python3-prompt-toolkit_2.0.10.bb)5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_2.0.10.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb
index d9ece8dabc..b4d20c2cd7 100644
--- a/meta-python/recipes-devtools/python/python3-prompt-toolkit_2.0.10.bb
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb
@@ -1,9 +1,10 @@
SUMMARY = "Library for building powerful interactive command lines in Python"
+HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
-SRC_URI[md5sum] = "5016c523e603cd7119644fbc0f00ce53"
-SRC_URI[sha256sum] = "f15af68f66e664eaa559d4ac8a928111eebd5feda0c11738b5998045224829db"
+SRC_URI[md5sum] = "96ba0be8d3145eb70e3da25654987670"
+SRC_URI[sha256sum] = "563d1a4140b63ff9dd587bda9557cffb2fe73650205ab6f4383092fb882e7dc8"
inherit pypi setuptools3