aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2022-01-11 13:15:36 +0100
committerKhem Raj <raj.khem@gmail.com>2022-01-11 17:51:55 -0800
commit5c65fb53e3e0ebe08dbab168ef0d13dfd61422cd (patch)
tree73730f10b0abc8b7d10b655bf5dcb84eb51e328b
parent342de9bf51f27362e7d1d4f1d55d8548cfa7504c (diff)
downloadmeta-openembedded-5c65fb53e3e0ebe08dbab168ef0d13dfd61422cd.tar.gz
zenity: Upgrade 3.32.0 -> 3.41.0 / meson build / rework
* 3.41.0 looks a stable version. See Chanhelog below and e.g Fedora ships 3.41.0 too * Instead of deleting gdialog, fix it and split out into separate package * Add PACKAGECONFIGs for libnotify and webkitgtk - disabled by default Zenity 3.41.0 - Port to meson (Logan Rathbone) - Code cleanups (Simon McVittie) - Translation updates (various contributors; see git log history) Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/zenity/zenity/0001-Harcode-shebang-to-avoid-pointing-to-build-system-s-.patch28
-rw-r--r--meta-gnome/recipes-gnome/zenity/zenity_3.32.0.bb22
-rw-r--r--meta-gnome/recipes-gnome/zenity/zenity_3.41.0.bb25
3 files changed, 53 insertions, 22 deletions
diff --git a/meta-gnome/recipes-gnome/zenity/zenity/0001-Harcode-shebang-to-avoid-pointing-to-build-system-s-.patch b/meta-gnome/recipes-gnome/zenity/zenity/0001-Harcode-shebang-to-avoid-pointing-to-build-system-s-.patch
new file mode 100644
index 0000000000..e054ff7448
--- /dev/null
+++ b/meta-gnome/recipes-gnome/zenity/zenity/0001-Harcode-shebang-to-avoid-pointing-to-build-system-s-.patch
@@ -0,0 +1,28 @@
+From c8be0d5e7d17930d819635df6570fa5331a5dedd Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Mon, 10 Jan 2022 20:18:00 +0100
+Subject: [PATCH] Harcode shebang to avoid pointing to build system's perl
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Pending
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ src/gdialog.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gdialog.in b/src/gdialog.in
+index 2fc4633..f891861 100755
+--- a/src/gdialog.in
++++ b/src/gdialog.in
+@@ -1,4 +1,4 @@
+-#!@PERL@
++#!/usr/bin/env perl
+
+ # gdialog -> zenity conversion wrapper
+ #
+--
+2.31.1
+
diff --git a/meta-gnome/recipes-gnome/zenity/zenity_3.32.0.bb b/meta-gnome/recipes-gnome/zenity/zenity_3.32.0.bb
deleted file mode 100644
index f5f1f998ff..0000000000
--- a/meta-gnome/recipes-gnome/zenity/zenity_3.32.0.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Display dialog boxes from the command line and shell scripts"
-SECTION = "x11/gnome"
-LICENSE = "GPLv2+"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
-
-inherit gnomebase itstool gnome-help features_check gettext
-
-DEPENDS = " \
- yelp-tools-native \
- gtk+3 \
-"
-
-REQUIRED_DISTRO_FEATURES = "x11"
-
-SRC_URI[archive.md5sum] = "ba2b2a13248773b4ec0fd323d95e6d5a"
-SRC_URI[archive.sha256sum] = "e786e733569c97372c3ef1776e71be7e7599ebe87e11e8ad67dcc2e63a82cd95"
-
-do_install:append() {
- # Remove gdialog compatibility helper - we don't want to pull in perl
- rm ${D}${bindir}/gdialog
-}
diff --git a/meta-gnome/recipes-gnome/zenity/zenity_3.41.0.bb b/meta-gnome/recipes-gnome/zenity/zenity_3.41.0.bb
new file mode 100644
index 0000000000..ea1db575e4
--- /dev/null
+++ b/meta-gnome/recipes-gnome/zenity/zenity_3.41.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Display dialog boxes from the command line and shell scripts"
+SECTION = "x11/gnome"
+LICENSE = "LGPL-2.1-or-later"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase pkgconfig itstool gnome-help features_check gettext
+
+DEPENDS = " \
+ yelp-tools-native \
+ gtk+3 \
+"
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI[archive.sha256sum] = "19b676c3510e22badfcc3204062d432ba537402f5e0ae26128c0d90c954037e1"
+SRC_URI += "file://0001-Harcode-shebang-to-avoid-pointing-to-build-system-s-.patch"
+
+PACKAGECONFIG[libnotify] = "-Dlibnotify=true,-Dlibnotify=false,libnotify"
+PACKAGECONFIG[webkitgtk] = "-Dwebkitgtk=true,-Dwebkitgtk=false,webkitgtk"
+
+PACKAGES =+ "${PN}-gdialog"
+FILES:${PN}-gdialog = "${bindir}/gdialog"
+RDEPENDS:${PN}-gdialog += "perl"