aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-01-28 22:23:19 -0800
committerKhem Raj <raj.khem@gmail.com>2019-01-30 13:34:49 -0800
commit69c99033461e769f9a3359d324a1956e5b88dd78 (patch)
treed15617bcc7b04ded16589e35b83498e79861c289
parent9ada8b1306dad1a4675765b6ea54f1eb390c13dc (diff)
downloadmeta-openembedded-69c99033461e769f9a3359d324a1956e5b88dd78.tar.gz
python-twisted: Remove ${PN}-src
This fixes the QA errors about double defining this in PACKAGES it seems to be removed in py3 version of recipe too so we just do it in inc file so both recipes can use it Fix a typo in specifying rdep Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-twisted.inc4
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb2
2 files changed, 2 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python-twisted.inc b/meta-python/recipes-devtools/python/python-twisted.inc
index 01616b168b..456adf4c39 100644
--- a/meta-python/recipes-devtools/python/python-twisted.inc
+++ b/meta-python/recipes-devtools/python/python-twisted.inc
@@ -35,7 +35,6 @@ PACKAGES += "\
"
PACKAGES =+ "\
- ${PN}-src \
${PN}-bin \
"
@@ -242,9 +241,10 @@ FILES_${PN}-doc += " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \
"
-RDEPENDS_{PN}-src = "${PN}"
+RDEPENDS_${PN}-src = "${PN}"
FILES_${PN}-src = " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \
"
+
diff --git a/meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb b/meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb
index 6bd8c52eb0..dfb9d4a4cc 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_18.4.0.bb
@@ -1,8 +1,6 @@
inherit pypi setuptools3
require python-twisted.inc
-PACKAGES_remove = "${PN}-src"
-
FILES_${PN}-core_append += " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \