aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 14:50:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:05 +0200
commita61c15efe444c8917da50264817b44cdcb775fc9 (patch)
tree816aef1c3c69b17f7e6740f20c6cf5195236e0b4
parentfe76f1ab77c118e077d2c98f405b6b78ad35a124 (diff)
downloadmeta-openembedded-a61c15efe444c8917da50264817b44cdcb775fc9.tar.gz
zram: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/zram/zram/zram.service (renamed from meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service)0
-rw-r--r--meta-oe/recipes-extended/zram/zram_0.1.bb13
-rw-r--r--meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend20
3 files changed, 11 insertions, 22 deletions
diff --git a/meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service b/meta-oe/recipes-extended/zram/zram/zram.service
index 4a19367d93..4a19367d93 100644
--- a/meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service
+++ b/meta-oe/recipes-extended/zram/zram/zram.service
diff --git a/meta-oe/recipes-extended/zram/zram_0.1.bb b/meta-oe/recipes-extended/zram/zram_0.1.bb
index 85262647c0..115e6437fd 100644
--- a/meta-oe/recipes-extended/zram/zram_0.1.bb
+++ b/meta-oe/recipes-extended/zram/zram_0.1.bb
@@ -2,22 +2,31 @@ DESCRIPTION = "Linux zram compressed in-memory swap"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-inherit allarch update-rc.d
+inherit allarch update-rc.d systemd
RDEPENDS_${PN} = "util-linux-swaponoff kmod kernel-module-zram"
-PR = "r0"
+PR = "r3"
SRC_URI = " \
file://init \
+ file://zram.service \
"
do_install () {
# Sysvinit
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/zram
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/zram.service ${D}${systemd_unitdir}/system
}
FILES_${PN} = "${sysconfdir}/init.d"
INITSCRIPT_NAME = "zram"
INITSCRIPT_PARAMS = "start 05 2 3 4 5 . stop 22 0 1 6 ."
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "zram.service"
diff --git a/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend b/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend
deleted file mode 100644
index 227c1c7c6c..0000000000
--- a/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend
+++ /dev/null
@@ -1,20 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-PRINC := "${@int(PRINC) + 2}"
-
-inherit systemd
-
-SRC_URI += " \
- file://zram.service \
-"
-
-RPROVIDES_${PN} += "${PN}-systemd"
-RREPLACES_${PN} += "${PN}-systemd"
-RCONFLICTS_${PN} += "${PN}-systemd"
-SYSTEMD_SERVICE_${PN} = "zram.service"
-
-do_install_append() {
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/zram.service ${D}${systemd_unitdir}/system
-}
-