aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-29 18:13:54 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-11 07:58:57 -0800
commitae9c2bad8add4b4b1bc35a68195cf0486170e317 (patch)
treee6d4c5f6f8c88801b52707017cca6dd2cb0d8282
parent5a335fc7de0488d86a506608a823bf3c98e3ca28 (diff)
downloadmeta-openembedded-ae9c2bad8add4b4b1bc35a68195cf0486170e317.tar.gz
python-can: correct the RDEPENDS to work on a minimal python install
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-can.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-can_2.0.0b1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-can_2.0.0b1.bb5
3 files changed, 18 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-can.inc b/meta-python/recipes-devtools/python/python-can.inc
index 1dbc809900..ecfae3cffc 100644
--- a/meta-python/recipes-devtools/python/python-can.inc
+++ b/meta-python/recipes-devtools/python/python-can.inc
@@ -7,3 +7,14 @@ SRC_URI[md5sum] = "b2a164887c1c6a2a2490b5afb36e36db"
SRC_URI[sha256sum] = "b961b6ce75a7f08b586f4d2cae8cdc409881731b851fc405fa21cb16bad00d87"
PYPI_PACKAGE="python-can"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-argparse \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-importlib \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-sqlite3 \
+"
diff --git a/meta-python/recipes-devtools/python/python-can_2.0.0b1.bb b/meta-python/recipes-devtools/python/python-can_2.0.0b1.bb
index ec81a9e48d..a698ad3651 100644
--- a/meta-python/recipes-devtools/python/python-can_2.0.0b1.bb
+++ b/meta-python/recipes-devtools/python/python-can_2.0.0b1.bb
@@ -1,4 +1,6 @@
require python-can.inc
inherit pypi setuptools
-RDEPENDS_${PN} += "python-sqlite3"
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-zlib \
+"
diff --git a/meta-python/recipes-devtools/python/python3-can_2.0.0b1.bb b/meta-python/recipes-devtools/python/python3-can_2.0.0b1.bb
index a1d45b88a6..aaa9e811ce 100644
--- a/meta-python/recipes-devtools/python/python3-can_2.0.0b1.bb
+++ b/meta-python/recipes-devtools/python/python3-can_2.0.0b1.bb
@@ -1,4 +1,7 @@
require python-can.inc
inherit pypi setuptools3
-RDEPENDS_${PN} += "python3-sqlite3"
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-compression \
+"