aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Belisko <marek.belisko@open-nandra.com>2017-05-18 21:22:39 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-23 15:59:31 +0200
commitb063789560bfb9c60a7a15277b5b3a9839b5ba74 (patch)
treef4312942b7045a6acf22dc7145b16c3b694af24a
parentacbbd49577d049bf049a5c27e75777cdc2ad3c66 (diff)
downloadmeta-openembedded-b063789560bfb9c60a7a15277b5b3a9839b5ba74.tar.gz
libgpiod: add new recipe
libgpiod - C library and tools for interacting with the linux GPIO character device Since linux 4.8 the GPIO sysfs interface is deprecated. User space should use the character device instead. This library encapsulates the ioctl calls and data structures behind a straightforward API. Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta/recipes-support/libgpiod/libgpiod.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/libgpiod/libgpiod.bb b/meta/recipes-support/libgpiod/libgpiod.bb
new file mode 100644
index 0000000000..fe56f7b5cb
--- /dev/null
+++ b/meta/recipes-support/libgpiod/libgpiod.bb
@@ -0,0 +1,30 @@
+SUMMARY = "C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE = "https://github.com/brgl/libgpiod"
+
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
+
+UPSTREAM_CHECK_URI = "git://github.com/brgl/libgpiod/releases"
+
+SRC_URI = "git://github.com/brgl/libgpiod.git"
+
+SRCREV = "7ab5e53b69cce313ba87033a442cabd417f5d895"
+
+PV = "0.2+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+SRC_URI[md5sum] = "68f039487e940c15bbfc50a10ab4715b"
+SRC_URI[sha256sum] = "7d7085d4e9cb811742ca8c5fe03458067efaeaa8abc23968d2e3c56bcc2d2ef8"
+
+inherit autotools pkgconfig
+
+# enable tools
+PACKAGECONFIG ?= "tools"
+
+PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
+PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
+
+PACKAGES += " ${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}/*"