aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-29 15:17:16 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-11 07:58:57 -0800
commitbb497805f07f192118a280bdaa9ea44a26caae76 (patch)
tree2be2f1d2ece429609488a58bbb71c2955f5fb4a3
parent7e1e62d682448b2e276ec5b9c74627bdaa5a9503 (diff)
downloadmeta-openembedded-bb497805f07f192118a280bdaa9ea44a26caae76.tar.gz
pyrtm: break samples and unit tests into separate packages
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/pyrtm_0.4.2.bb21
1 files changed, 20 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
index 72f0921e70..2272da91a5 100644
--- a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
+++ b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
@@ -10,7 +10,26 @@ SRC_URI[sha256sum] = "b2d701b25ad3f9a1542057f3eb492c5c1d7dbe2b8d1e8f763043dcc14e
inherit pypi setuptools
+PACKAGES =+ "${PN}-tests ${PN}-samples"
+
+FILES_${PN}-samples += " \
+ ${PYTHON_SITEPACKAGES_DIR}/rtm/samples \
+"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/rtm/tests \
+"
+
RDEPENDS_${PN} += "\
${PYTHON_PN}-json \
${PYTHON_PN}-netclient \
- "
+"
+
+RDEPENDS_${PN}-samples += " \
+ ${PN} \
+"
+
+RDEPENDS_${PN}-tests += " \
+ ${PN} \
+ ${PYTHON_PN}-unittest \
+"