aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2017-06-01 09:42:49 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:24 +0200
commitd5f55bc60813704ab22287c347253fda48495335 (patch)
tree64e5d8145fc4abcd8046c0976716326cc05042ae
parentf53d17a1a91409cf8aa7e986e70e945e44453ded (diff)
downloadmeta-openembedded-d5f55bc60813704ab22287c347253fda48495335.tar.gz
python-msgpack: Add support for python3
Extend recipe to support python3 Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-msgpack.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-msgpack_0.4.8.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-msgpack_0.4.8.bb2
3 files changed, 13 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-msgpack.inc b/meta-python/recipes-devtools/python/python-msgpack.inc
new file mode 100644
index 0000000000..228ce59250
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-msgpack.inc
@@ -0,0 +1,9 @@
+SUMMARY = "MessagePack (de)serializer"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
+
+SRC_URI[md5sum] = "dcd854fb41ee7584ebbf35e049e6be98"
+SRC_URI[sha256sum] = "1a2b19df0f03519ec7f19f826afb935b202d8979b0856c6fb3dc28955799f886"
+
+PYPI_PACKAGE = "msgpack-python"
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-msgpack_0.4.8.bb b/meta-python/recipes-devtools/python/python-msgpack_0.4.8.bb
index 8a0ad8f88c..2c2c8f2add 100644
--- a/meta-python/recipes-devtools/python/python-msgpack_0.4.8.bb
+++ b/meta-python/recipes-devtools/python/python-msgpack_0.4.8.bb
@@ -1,9 +1,2 @@
-SUMMARY = "MessagePack (de)serializer"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
-
-SRC_URI[md5sum] = "dcd854fb41ee7584ebbf35e049e6be98"
-SRC_URI[sha256sum] = "1a2b19df0f03519ec7f19f826afb935b202d8979b0856c6fb3dc28955799f886"
-
-PYPI_PACKAGE = "msgpack-python"
-inherit pypi setuptools
+require python-msgpack.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-msgpack_0.4.8.bb b/meta-python/recipes-devtools/python/python3-msgpack_0.4.8.bb
new file mode 100644
index 0000000000..096d7ddcb8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-msgpack_0.4.8.bb
@@ -0,0 +1,2 @@
+require python-msgpack.inc
+inherit setuptools3