aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric BENARD <eric@eukrea.com>2012-11-12 16:57:11 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-13 12:58:46 +0100
commite23c48c67e5cb6b6b85880559d0767469a25d42a (patch)
treee3fc6783e1e86d8d1c9854721cdfbbd5b49fec8f
parentb622bac27636c856c134b66e2d4d00eceda747f5 (diff)
downloadmeta-openembedded-e23c48c67e5cb6b6b85880559d0767469a25d42a.tar.gz
mercurial-native: fix install
else host python is used leading to the following error if the host doesn't have the python headers installed : | Python headers are required to build Mercurial | make: *** [build] Error 1 Signed-off-by: Eric BĂ©nard <eric@eukrea.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial-native_1.9.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial-native_1.9.bb b/meta-oe/recipes-devtools/mercurial/mercurial-native_1.9.bb
index facf554037..41b29fbdf8 100644
--- a/meta-oe/recipes-devtools/mercurial/mercurial-native_1.9.bb
+++ b/meta-oe/recipes-devtools/mercurial/mercurial-native_1.9.bb
@@ -4,7 +4,7 @@ SECTION = "console/utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "python-native"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://mercurial.selenic.com/release/mercurial-${PV}.tar.gz"
SRC_URI[md5sum] = "d4842129fa2732eb6ed1180467bc32e2"
@@ -17,6 +17,10 @@ inherit native
EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} PREFIX=${prefix}"
+do_configure_append () {
+ sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile
+}
+
do_install () {
oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix}
}