aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-30 17:56:47 -0700
committerKhem Raj <raj.khem@gmail.com>2022-03-30 18:00:02 -0700
commitf36fe239ad6e34a1aeacc5a3ff8be0ed9646705a (patch)
tree36bff246335ce45a97b6fb91632205f7c9ad943c
parentf3a7de2bdfa8a3e9e360ad528a3f847e4c829b78 (diff)
downloadmeta-openembedded-f36fe239ad6e34a1aeacc5a3ff8be0ed9646705a.tar.gz
python3-wxgtk4: Use cross prefix with native wx-config
This ensures that it relocates the returns of queries w.r.t. target sysroot and not based on native sysroot where this tool itself resides and uses that by default. Fixes build issues seen on mips architecture Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Kai Kang <kai.kang@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
index af7b51d83b..e61b00efa4 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/wxPython-${PV}"
inherit pypi setuptools3 pkgconfig
-export WX_CONFIG = "${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config"
+export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR}'"
RDEPENDS:${PN} = "\
python3-difflib \