aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2022-01-10 00:08:47 -0800
committerKhem Raj <raj.khem@gmail.com>2022-01-11 17:51:55 -0800
commit0e93a3d7eea111ef1730fc718137005f6e2a821c (patch)
tree32057dc4b2bd11e48b7fb0bab583e17ba14c4b69 /meta-initramfs/recipes-devtools
parentc950d3966b446976ae5bd700d5ebcf4122eebb2a (diff)
downloadmeta-openembedded-0e93a3d7eea111ef1730fc718137005f6e2a821c.tar.gz
grubby: fix conflict with debianutils
Both of recipe grubby and debianutils provides installkernel, use update-alternative to resolve the conflict Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-devtools')
-rw-r--r--meta-initramfs/recipes-devtools/grubby/grubby_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/grubby/grubby_git.bb b/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
index d275387c85..43fcc1aee8 100644
--- a/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
+++ b/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
@@ -38,4 +38,8 @@ do_install_ptest() {
RDEPENDS:${PN} += "bash"
RDEPENDS:${PN}-ptest = "util-linux-getopt bash"
+inherit update-alternatives
+ALTERNATIVE_${PN} = "installkernel"
+ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
+
COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'