aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-31 20:27:25 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-01 07:49:06 -0700
commit689e8ed550d23fbdaeb71abc7a6c6f891469c5e2 (patch)
tree7a92a6e0186a00b8bd6e95b79baaab8cf9ff43fd /meta-networking/recipes-connectivity
parentb4dedcede9339b4947760b6910dc5bb62495f17f (diff)
downloadmeta-openembedded-689e8ed550d23fbdaeb71abc7a6c6f891469c5e2.tar.gz
dhcp-relay: Fix libtool files for internal bind build
The bundled libtool files are arcane and do not work in OE cross build environment, resulting in creating wrong entried in DT_NEEDED section as well as emitting build paths into rpaths into ELF files, therefore copy the OE provided libtool files to fix this issue Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb
index 2af41b217a..b178180ec8 100644
--- a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb
+++ b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb
@@ -38,6 +38,7 @@ EXTRA_OECONF = "--enable-paranoia \
--enable-libtool \
--with-randomdev=/dev/random \
"
+EXTRA_OEMAKE += "LIBTOOL='${S}/${HOST_SYS}-libtool'"
# Enable shared libs per dhcp README
do_configure_prepend () {
@@ -48,6 +49,9 @@ do_compile_prepend() {
tar xf ${S}/bind/bind.tar.gz -C ${S}/bind
install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.14/
install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/bind/bind-9.11.14/
+ cp -fpR ${S}/m4/*.m4 ${S}/bind/bind-9.11.14/libtool.m4/
+ rm -rf ${S}/bind/bind-9.11.14/libtool
+ install -m 0755 ${S}/${HOST_SYS}-libtool ${S}/bind/bind-9.11.14/
}
do_install_append () {