aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2020-07-29 14:50:15 +0200
committerKhem Raj <raj.khem@gmail.com>2020-07-31 13:22:52 -0700
commit729fbf0b9c68ea418d7bbb57d67c8895fe7e8fe0 (patch)
treede6a6a5169443fbc4f9d9a87b3d77326851a3355 /meta-networking/recipes-connectivity
parentcbf752d9e4e23f828fe193df773aef2cc22b5385 (diff)
downloadmeta-openembedded-729fbf0b9c68ea418d7bbb57d67c8895fe7e8fe0.tar.gz
openconnect: update to 8.10
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch71
-rw-r--r--meta-networking/recipes-connectivity/openconnect/openconnect_8.10.bb (renamed from meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb)9
2 files changed, 6 insertions, 74 deletions
diff --git a/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch b/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch
deleted file mode 100644
index 623ec101d3..0000000000
--- a/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From de78bcac5e1fd13de0371c8e14b062b8786ade56 Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Sun, 2 Feb 2020 15:53:05 +0000
-Subject: [PATCH] trojans/tncc-wrapper.py: convert to python3
-
-Use 2to3 to convert the script to python3.
-
-Upstream-Status: Pending
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- trojans/tncc-wrapper.py | 14 +++++++-------
- 1 file changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/trojans/tncc-wrapper.py b/trojans/tncc-wrapper.py
-index 0d4587bf..1a9a1f4d 100755
---- a/trojans/tncc-wrapper.py
-+++ b/trojans/tncc-wrapper.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python2
-+#!/usr/bin/python3
-
- # Lifted from Russ Dill's juniper-vpn-wrap.py, thus:
- #
-@@ -18,19 +18,19 @@
-
- import subprocess
- import mechanize
--import cookielib
-+import http.cookiejar
- import getpass
- import sys
- import os
- import zipfile
--import urllib
-+import urllib.request, urllib.parse, urllib.error
- import socket
- import ssl
- import errno
- import argparse
- import atexit
- import signal
--import ConfigParser
-+import configparser
- import time
- import binascii
- import hmac
-@@ -39,7 +39,7 @@ import hashlib
- def mkdir_p(path):
- try:
- os.mkdir(path)
-- except OSError, exc:
-+ except OSError as exc:
- if exc.errno == errno.EEXIST and os.path.isdir(path):
- pass
- else:
-@@ -64,9 +64,9 @@ class Tncc:
- if zipfile.ZipFile(self.tncc_jar, 'r').testzip() is not None:
- raise Exception()
- except:
-- print 'Downloading tncc.jar...'
-+ print('Downloading tncc.jar...')
- mkdir_p(os.path.expanduser('~/.juniper_networks'))
-- urllib.urlretrieve('https://' + self.vpn_host
-+ urllib.request.urlretrieve('https://' + self.vpn_host
- + '/dana-cached/hc/tncc.jar', self.tncc_jar)
-
- with zipfile.ZipFile(self.tncc_jar, 'r') as jar:
---
-2.20.1
-
diff --git a/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb b/meta-networking/recipes-connectivity/openconnect/openconnect_8.10.bb
index 597c1920cf..a486cf0e05 100644
--- a/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
+++ b/meta-networking/recipes-connectivity/openconnect/openconnect_8.10.bb
@@ -4,9 +4,8 @@ LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=243b725d71bb5df4a1e5920b344b86ad"
SRC_URI = " \
git://git.infradead.org/users/dwmw2/openconnect.git \
- file://0001-trojans-tncc-wrapper.py-convert-to-python3.patch \
"
-SRCREV = "ea73851969ae7a6ea54fdd2d2b8c94776af24b2a"
+SRCREV = "9d287e40c57233190a51b6434ba7345370e36f38"
DEPENDS = "vpnc libxml2 krb5 gettext-native"
RDEPENDS_${PN} = "bash python3-core vpnc-script"
@@ -23,7 +22,11 @@ PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite,"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig
+inherit autotools pkgconfig bash-completion
EXTRA_OECONF += "--with-vpnc-script=${sysconfdir}/vpnc/vpnc-script \
--disable-static"
+
+do_install_append() {
+ rm ${D}/usr/libexec/openconnect/hipreport-android.sh
+}