aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2021-01-03 12:52:42 +0800
committerKhem Raj <raj.khem@gmail.com>2021-01-05 09:16:25 -0800
commit00958a182e8edfcc0b4df215e75237077e83bb32 (patch)
treedb49446f049cd2226f1e121e78ba0b83cb186013 /meta-networking/recipes-filter
parent752bb30c39c30411eee2364d045863a6c1569c62 (diff)
downloadmeta-openembedded-00958a182e8edfcc0b4df215e75237077e83bb32.tar.gz
ebtables: Add symbol link /sbin/ebtables
The original /sbin/ebtables has been moved to /usr/sbin/ebtables-legacy. But the old path is still used by some other software libvirt. libvirtd[809]: direct firewall backend requested, but /sbin/ebtables is not available: No such file or directory As stated in the related change in ebtable git repo: The new -legacy binary has no problem if called via a symlink with the 'ebtables' name, so users can still name this binary with whatever name. So we add a symbol link from /usr/sbin/ebtables-legacy to /sbin/ebtables. Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-filter')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
index c13ed7b3bf..bc33c18c0b 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
@@ -38,6 +38,9 @@ do_install_append () {
sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/ebtables.service
install -m 0755 ${WORKDIR}/ebtables.common ${D}${sbindir}/ebtables.common
fi
+
+ install -d ${D}${base_sbindir}
+ ln -sf ${sbindir}/ebtables-legacy ${D}${base_sbindir}/ebtables
}
do_configure_prepend () {