aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-networking/recipes-filter
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-filter')
-rw-r--r--meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.1.bb4
-rw-r--r--meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.6.bb2
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb16
-rw-r--r--meta-networking/recipes-filter/ipset/ipset_7.11.bb2
-rw-r--r--meta-networking/recipes-filter/nftables/nftables_0.9.9.bb6
5 files changed, 15 insertions, 15 deletions
diff --git a/meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.1.bb b/meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.1.bb
index bc9297eab6..48723d92b1 100644
--- a/meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.1.bb
+++ b/meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.1.bb
@@ -29,5 +29,5 @@ do_install() {
sed -i -e 's%#!/bin/bash%#!/bin/sh%g' ${D}${datadir}/arno-iptables-firewall/plugins/dyndns-host-open-helper
}
-SYSTEMD_SERVICE_${PN} = "arno-iptables-firewall.service"
-FILES_${PN} += "${systemd_unitdir}/system/arno-iptables-firewall.service"
+SYSTEMD_SERVICE:${PN} = "arno-iptables-firewall.service"
+FILES:${PN} += "${systemd_unitdir}/system/arno-iptables-firewall.service"
diff --git a/meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.6.bb b/meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.6.bb
index ad50a89a43..0e009da029 100644
--- a/meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.6.bb
+++ b/meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.6.bb
@@ -19,7 +19,7 @@ inherit autotools update-rc.d pkgconfig
INITSCRIPT_NAME = "conntrackd"
-do_install_append() {
+do_install:append() {
install -d ${D}/${sysconfdir}/conntrackd
install -d ${D}/${sysconfdir}/init.d
install -m 0644 ${S}/doc/sync/ftfw/conntrackd.conf ${D}/${sysconfdir}/conntrackd/conntrackd.conf.sample
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
index bc33c18c0b..21e5c1877e 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
@@ -6,9 +6,9 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=53b4a999993871a28ab1488fdbd2e73e"
SECTION = "net"
-RDEPENDS_${PN} += "bash perl"
+RDEPENDS:${PN} += "bash perl"
-RRECOMMENDS_${PN} += "kernel-module-ebtables \
+RRECOMMENDS:${PN} += "kernel-module-ebtables \
"
SRC_URI = "http://ftp.netfilter.org/pub/ebtables/ebtables-${PV}.tar.gz \
@@ -18,14 +18,14 @@ SRC_URI = "http://ftp.netfilter.org/pub/ebtables/ebtables-${PV}.tar.gz \
file://ebtables.service \
"
-SRC_URI_append_libc-musl = " file://0010-Adjust-header-include-sequence.patch"
+SRC_URI:append:libc-musl = " file://0010-Adjust-header-include-sequence.patch"
SRC_URI[md5sum] = "071c8b0a59241667a0044fb040d4fc72"
SRC_URI[sha256sum] = "b71f654784a726329f88b412ef7b96b4e5d786ed2bd28193ed7b4c0d677dfd2a"
inherit systemd autotools
-do_install_append () {
+do_install:append () {
# Replace upstream ebtables-save perl script with Fedora bash based rewrite
# http://pkgs.fedoraproject.org/cgit/rpms/ebtables.git/tree/ebtables-save
rm -f ${D}${sbindir}/ebtables-legacy-save
@@ -43,11 +43,11 @@ do_install_append () {
ln -sf ${sbindir}/ebtables-legacy ${D}${base_sbindir}/ebtables
}
-do_configure_prepend () {
+do_configure:prepend () {
( cd ${S}; ./autogen.sh )
}
-FILES_${PN}-dbg += "${base_libdir}/ebtables/.debug"
-FILES_${PN} += "${base_libdir}/ebtables/*.so"
+FILES:${PN}-dbg += "${base_libdir}/ebtables/.debug"
+FILES:${PN} += "${base_libdir}/ebtables/*.so"
-SYSTEMD_SERVICE_${PN} = "ebtables.service"
+SYSTEMD_SERVICE:${PN} = "ebtables.service"
diff --git a/meta-networking/recipes-filter/ipset/ipset_7.11.bb b/meta-networking/recipes-filter/ipset/ipset_7.11.bb
index 693aa90318..3e64f41596 100644
--- a/meta-networking/recipes-filter/ipset/ipset_7.11.bb
+++ b/meta-networking/recipes-filter/ipset/ipset_7.11.bb
@@ -16,6 +16,6 @@ inherit autotools pkgconfig module-base
EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
-RRECOMMENDS_${PN} = "\
+RRECOMMENDS:${PN} = "\
kernel-module-ip-set \
"
diff --git a/meta-networking/recipes-filter/nftables/nftables_0.9.9.bb b/meta-networking/recipes-filter/nftables/nftables_0.9.9.bb
index cbe2bb3996..cf7c01bbcf 100644
--- a/meta-networking/recipes-filter/nftables/nftables_0.9.9.bb
+++ b/meta-networking/recipes-filter/nftables/nftables_0.9.9.bb
@@ -24,8 +24,8 @@ PACKAGECONFIG[xtables] = "--with-xtables, --without-xtables, iptables"
inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
-RRECOMMENDS_${PN} += "kernel-module-nf-tables"
+RRECOMMENDS:${PN} += "kernel-module-nf-tables"
PACKAGES =+ "${PN}-python"
-FILES_${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
-RDEPENDS_${PN}-python = "python3-core python3-json ${PN}"
+FILES:${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
+RDEPENDS:${PN}-python = "python3-core python3-json ${PN}"