aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20220627.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2022-08-22 16:34:33 +0000
committerKhem Raj <raj.khem@gmail.com>2022-08-22 14:13:37 -0700
commite2a2320a7953fd70e8b416f9f6741d0b6654f280 (patch)
treef22e3444bf4415d5c2d44d6c13b7da16a4462a69 /meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20220627.bb
parente75e0cebacbb6efd1785e4392a32c86818810367 (diff)
downloadmeta-openembedded-e2a2320a7953fd70e8b416f9f6741d0b6654f280.tar.gz
wireguard-module: 1.0.20210219 -> 1.0.20220627
Also change the git protocol to https. Relevant changes: - 18fbcd6 version: bump - 3ec3e82 compat: handle backported rng and blake2s - ba45dd6 qemu: give up on RHEL8 in CI - c7560fd qemu: set panic_on_warn=1 from cmdline - 33c87a1 qemu: use vports on arm - 894152a netns: limit parallelism to $(nproc) tests at once - f888673 netns: make routing loop test non-fatal - f9d9b4d device: check for metadata_dst with skb_valid_dst() - f909532 qemu: enable ACPI for SMP - ec89ca6 socket: ignore v6 endpoints when ipv6 is disabled - fa32671 socket: free skb in send6 when ipv6 is disabled - ffb8cd6 qemu: simplify RNG seeding - 4eff63d queueing: use CFI-safe ptr_ring cleanup function - 273018b crypto: curve25519-x86_64: use in/out register constraints more precisely - 4f4c019 compat: drop Ubuntu 14.04 - 743eef2 version: bump - 3c9f3b6 crypto: curve25519-x86_64: solve register constraints with reserved registers - 8e40dd6 compat: udp_tunnel: don't take reference to non-init namespace - ea6b8e7 compat: siphash: use _unaligned version by default - 5325bc8 ratelimiter: use kvcalloc() instead of kvzalloc() - e44c78c receive: drop handshakes if queue lock is contended - 5707d38 receive: use ring buffer for incoming handshakes - 68abb1b device: reset peer src endpoint when netns exits - ea3f5fb main: rename 'mod_init' & 'mod_exit' functions to be module-specific - cb001d4 netns: actually test for routing loops - 2715e64 compat: update for RHEL 8.5 - 2974725 compat: account for grsecurity backports and changes - 50dda8c compat: account for latest c8s backports - d378f93 version: bump - fb4a0da qemu: increase default dmesg log size - 8f4414d qemu: add disgusting hacks for RHEL 8 - fd7a462 allowedips: add missing __rcu annotation to satisfy sparse - 383461d allowedips: free empty intermediate nodes when removing single node - 03add82 allowedips: allocate nodes in kmem_cache - b56d48c allowedips: remove nodes in O(1) - 3c14c4b allowedips: initialize list head in selftest - 4d8b7ed peer: allocate in kmem_cache - 6fbc0e6 global: use synchronize_net rather than synchronize_rcu - 405caf0 kbuild: do not use -O3 - b50ef4d netns: make sure rp_filter is disabled on vethc - e67b722 version: bump - 1edffe2 Revert "compat: skb_mark_not_on_list will be backported to Ubuntu 18.04" - 2cf9543 compat: update and improve detection of CentOS Stream 8 - 122f06b compat: icmp_ndo_send functions were backported extensively Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20220627.bb')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20220627.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20220627.bb b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20220627.bb
new file mode 100644
index 0000000000..d80bdd87ab
--- /dev/null
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20220627.bb
@@ -0,0 +1,30 @@
+require wireguard.inc
+
+SRCREV = "18fbcd68a35a892527345dc5679d0b2d860ee004"
+
+SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat;protocol=https;branch=master"
+
+inherit module kernel-module-split
+
+DEPENDS = "virtual/kernel libmnl"
+
+# This module requires Linux 3.10 higher and several networking related
+# configuration options. For exact kernel requirements visit:
+# https://www.wireguard.io/install/#kernel-requirements
+
+EXTRA_OEMAKE:append = " \
+ KERNELDIR=${STAGING_KERNEL_DIR} \
+ "
+
+MAKE_TARGETS = "module"
+MODULES_INSTALL_TARGET = "module-install"
+
+RRECOMMENDS:${PN} = "kernel-module-xt-hashlimit"
+MODULE_NAME = "wireguard"
+
+
+# WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required.
+# OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds
+# for reference machines e.g. qemu
+EXCLUDE_FROM_WORLD = "1"
+