aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@foundries.io>2023-11-09 09:04:35 -0300
committerKhem Raj <raj.khem@gmail.com>2023-11-09 20:47:44 -0800
commit865411fbde1f3489e77ad186e669b5c315485ce1 (patch)
treeb4a5f1003e7ae6344b720769541d3ab8d6d2ea57 /meta-networking/recipes-kernel
parent9281dbcc217c3517e45106af36ae422f5af01d65 (diff)
downloadmeta-openembedded-865411fbde1f3489e77ad186e669b5c315485ce1.tar.gz
wireguard-tools: Use PACKAGECONFIG to select wg-quick and bash-completion
Condition the creation of some files and their consequences to a PACKAGECONFIG, which can be overridden outside the meta layer. It removes the sub package wireguard-tools-wg-quick as PACKAGECONFIG is supposed to work to configure a package only, and not deal with sub packages. Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-kernel')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
index 20435338c3..8def54ece6 100644
--- a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
@@ -11,24 +11,22 @@ do_install () {
oe_runmake DESTDIR="${D}" PREFIX="${prefix}" SYSCONFDIR="${sysconfdir}" \
SYSTEMDUNITDIR="${systemd_system_unitdir}" \
WITH_SYSTEMDUNITS=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'yes', '', d)} \
- WITH_BASHCOMPLETION=yes \
- WITH_WGQUICK=yes \
+ ${PACKAGECONFIG_CONFARGS} \
install
}
-PACKAGES += "${PN}-wg-quick"
+PACKAGECONFIG ??= "bash-completion wg-quick"
+
+PACKAGECONFIG[bash-completion] = "WITH_BASHCOMPLETION=yes,WITH_BASHCOMPLETION=no,,bash,,"
+PACKAGECONFIG[wg-quick] = "WITH_WGQUICK=yes,WITH_WGQUICK=no,,bash,,"
FILES:${PN} = " \
${bindir}/wg \
${sysconfdir} \
-"
-FILES:${PN}-wg-quick = " \
${bindir}/wg-quick \
${systemd_system_unitdir} \
"
-RDEPENDS:${PN}-wg-quick = "${PN} bash"
RRECOMMENDS:${PN} = " \
kernel-module-wireguard \
- ${PN}-wg-quick \
"