aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/tinyproxy/tinyproxy_1.10.0.bb
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2018-09-18 16:30:35 +0200
committerKhem Raj <raj.khem@gmail.com>2018-09-24 11:49:45 -0700
commitfa1156b91a96103bb3f6b2d0943b81044d9ef1ee (patch)
treef22845a5acbe1ef17014333d69f3798f57a88ea2 /meta-networking/recipes-support/tinyproxy/tinyproxy_1.10.0.bb
parenta5718b30328c2bf208723514e934f71890fabcb3 (diff)
downloadmeta-openembedded-fa1156b91a96103bb3f6b2d0943b81044d9ef1ee.tar.gz
tinyproxy: upgrade to version 1.10.0
Highlights of this upgrade: * tinyproxy binary is not installed to /usr/sbin now. * removed a deprecated configure parameter. * reworked disable-documentation.patch. Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/tinyproxy/tinyproxy_1.10.0.bb')
-rw-r--r--meta-networking/recipes-support/tinyproxy/tinyproxy_1.10.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/tinyproxy/tinyproxy_1.10.0.bb b/meta-networking/recipes-support/tinyproxy/tinyproxy_1.10.0.bb
new file mode 100644
index 0000000000..144dcf33ac
--- /dev/null
+++ b/meta-networking/recipes-support/tinyproxy/tinyproxy_1.10.0.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Lightweight http(s) proxy daemon"
+HOMEPAGE = "https://tinyproxy.github.io/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.gz \
+ file://disable-documentation.patch \
+ file://tinyproxy.service"
+
+SRC_URI[md5sum] = "423047c8dc53a15e19f78e238198549c"
+SRC_URI[sha256sum] = "6020955e6a0ef0ef898ad5bb17a448c47f9e4c003c464b4ae7c4dba063272055"
+
+EXTRA_OECONF += " \
+ --enable-filter \
+ --enable-transparent \
+ --enable-reverse \
+ --enable-upstream \
+ --enable-xtinyproxy \
+ "
+
+inherit autotools systemd useradd
+
+#User specific
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--system --home /dev/null \
+ --no-user-group --gid nogroup tinypoxy"
+
+SYSTEMD_PACKAGES += "${BPN}"
+SYSTEMD_SERVICE_${PN} = "tinyproxy.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/tinyproxy.service ${D}${systemd_system_unitdir}
+ fi
+}