aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorJens Rehsack <rehsack@gmail.com>2015-11-19 20:44:32 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2016-01-04 12:58:10 -0500
commit0db903b44c8f983823a4f35622567efbc13f0f5b (patch)
tree256f632ccd3cda26e923adc79c0e48cc3a4389c4 /meta-networking
parent40d6a19aa300eb114ea4aa2de3c27a3fc22706f7 (diff)
downloadmeta-openembedded-0db903b44c8f983823a4f35622567efbc13f0f5b.tar.gz
talloc: rename to libtalloc and cleanup dependency mess
To avoid errors when building dev-images (talloc-dev is missing), and to avoid insane empty packages for that, rename talloc -> libtalloc as libtevent shows. With that, remove dependencies to attr/xattr - unless explicitely enabled via PACKAGECONFIG. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.1.12.bb2
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils_git.bb2
-rw-r--r--meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb2
-rw-r--r--meta-networking/recipes-support/libldb/libldb_1.1.17.bb6
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc/avoid-attr-unless-wanted.patch20
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc_2.1.1.bb (renamed from meta-networking/recipes-support/talloc/talloc_2.1.1.bb)25
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb3
7 files changed, 37 insertions, 23 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb
index cb29ab9d95..40afce886e 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb
@@ -40,7 +40,7 @@ SRC_URI[sha256sum] = "033604674936bf5c77d7df299b0626052b84a41505a6a6afe902f6274f
inherit systemd waf-samba cpan-base perlnative
-DEPENDS += "readline virtual/libiconv zlib popt talloc libtdb libtevent libldb krb5 ctdb libbsd cyrus-sasl"
+DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libldb krb5 ctdb libbsd cyrus-sasl"
SYSVINITTYPE_linuxstdbase = "lsb"
diff --git a/meta-networking/recipes-support/cifs/cifs-utils_git.bb b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
index 00617c9f2b..49a1aeccee 100644
--- a/meta-networking/recipes-support/cifs/cifs-utils_git.bb
+++ b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
@@ -17,7 +17,7 @@ PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
# when enabled, it creates ${bindir}/cifscreds and --ignore-fail-on-non-empty in do_install_append is needed
PACKAGECONFIG[cifscreds] = "--enable-cifscreds,--disable-cifscreds,keyutils"
# when enabled, it creates ${sbindir}/cifs.upcall and --ignore-fail-on-non-empty in do_install_append is needed
-PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 talloc keyutils"
+PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 libtalloc keyutils"
inherit autotools pkgconfig
diff --git a/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb b/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb
index 5718c5ffbe..a65527e9d0 100644
--- a/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb
+++ b/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb
@@ -26,7 +26,7 @@ inherit autotools-brokensep pkgconfig systemd
PARALLEL_MAKE = ""
-DEPENDS += "popt libtevent talloc"
+DEPENDS += "popt libtevent libtalloc"
do_configure() {
oe_runconf
diff --git a/meta-networking/recipes-support/libldb/libldb_1.1.17.bb b/meta-networking/recipes-support/libldb/libldb_1.1.17.bb
index 44f061ab6b..e587858f53 100644
--- a/meta-networking/recipes-support/libldb/libldb_1.1.17.bb
+++ b/meta-networking/recipes-support/libldb/libldb_1.1.17.bb
@@ -3,9 +3,9 @@ HOMEPAGE = "http://ldb.samba.org"
SECTION = "libs"
LICENSE = "LGPL-3.0+ & LGPL-2.1+ & GPL-3.0+"
-DEPENDS += "libtdb talloc libtevent popt"
-RDEPENDS_${PN} += "libtevent popt libtalloc openldap"
-RDEPENDS_pyldb += "python libtdb libtalloc"
+DEPENDS += "libtdb libtalloc libtevent popt"
+RDEPENDS_${PN} += "openldap"
+RDEPENDS_pyldb += "python"
SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \
file://do-not-import-target-module-while-cross-compile.patch \
diff --git a/meta-networking/recipes-support/libtalloc/libtalloc/avoid-attr-unless-wanted.patch b/meta-networking/recipes-support/libtalloc/libtalloc/avoid-attr-unless-wanted.patch
new file mode 100644
index 0000000000..a3ee9ccd97
--- /dev/null
+++ b/meta-networking/recipes-support/libtalloc/libtalloc/avoid-attr-unless-wanted.patch
@@ -0,0 +1,20 @@
+--- a/lib/replace/wscript 2015-11-13 16:04:04.000000000 +0100
++++ b/lib/replace/wscript 2015-11-13 16:23:20.000000000 +0100
+@@ -636,8 +636,6 @@
+ if not bld.CONFIG_SET('HAVE_INET_ATON'): REPLACE_SOURCE += ' inet_aton.c'
+ if not bld.CONFIG_SET('HAVE_INET_NTOP'): REPLACE_SOURCE += ' inet_ntop.c'
+ if not bld.CONFIG_SET('HAVE_INET_PTON'): REPLACE_SOURCE += ' inet_pton.c'
+- if not bld.CONFIG_SET('HAVE_GETXATTR') or bld.CONFIG_SET('XATTR_ADDITIONAL_OPTIONS'):
+- REPLACE_SOURCE += ' xattr.c'
+
+ bld.SAMBA_LIBRARY('replace',
+ source=REPLACE_SOURCE,
+@@ -648,7 +646,7 @@
+ # at the moment:
+ # hide_symbols=bld.BUILTIN_LIBRARY('replace'),
+ private_library=True,
+- deps='crypt dl nsl socket rt attr' + extra_libs)
++ deps='crypt dl nsl socket rt ' + extra_libs)
+
+ bld.SAMBA_SUBSYSTEM('replace-test',
+ source='''test/testsuite.c test/strptime.c
diff --git a/meta-networking/recipes-support/talloc/talloc_2.1.1.bb b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.1.bb
index 89c390f01d..9016f42af1 100644
--- a/meta-networking/recipes-support/talloc/talloc_2.1.1.bb
+++ b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.1.bb
@@ -3,7 +3,9 @@ HOMEPAGE = "http://talloc.samba.org"
SECTION = "libs"
LICENSE = "LGPL-3.0+ & GPL-3.0+"
-SRC_URI = "http://samba.org/ftp/${BPN}/${BPN}-${PV}.tar.gz"
+DEPENDS += "libbsd"
+
+SRC_URI = "http://samba.org/ftp/${BPN}/talloc-${PV}.tar.gz"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b \
file://${COREBASE}/meta/files/common-licenses/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891"
@@ -12,6 +14,12 @@ SRC_URI[sha256sum] = "3e29ce6c3ba3c4f7c2d57ce8cf0fbc24c86618c519f2b2fb6a45902548
inherit waf-samba
+PACKAGECONFIG[attr] = ",,attr"
+
+SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
+
+S = "${WORKDIR}/talloc-${PV}"
+
EXTRA_OECONF += "--disable-rpath \
--disable-rpath-install \
--bundled-libraries=NONE \
@@ -20,20 +28,7 @@ EXTRA_OECONF += "--disable-rpath \
--with-libiconv=${STAGING_DIR_HOST}${prefix}\
"
-PACKAGES += "libtalloc libtalloc-dbg libtalloc-dev pytalloc pytalloc-dbg pytalloc-dev"
-
-#ALLOW_EMPTY_${PN} = "1"
-FILES_${PN} = ""
-FILES_${PN}-dev = ""
-FILES_${PN}-dbg = ""
-
-FILES_libtalloc = "${libdir}/libtalloc.so.2 \
- ${libdir}/libtalloc.so.2.1.1"
-FILES_libtalloc-dbg = "/usr/src/debug/ \
- ${libdir}/.debug/libtalloc.so.2.1.1"
-FILES_libtalloc-dev = "${includedir}/ \
- ${libdir}/libtalloc.so \
- ${libdir}/pkgconfig/"
+PACKAGES += "pytalloc pytalloc-dbg pytalloc-dev"
FILES_pytalloc = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/* \
${libdir}/libpytalloc-util.so.2 \
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
index f297f30e12..36ce7d6f77 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
@@ -3,8 +3,7 @@ HOMEPAGE = "http://tevent.samba.org"
SECTION = "libs"
LICENSE = "LGPLv3+"
-DEPENDS += "talloc libcap"
-RDEPENDS_${PN} += "libtalloc"
+DEPENDS += "libtalloc libcap"
RDEPENDS_python-tevent = "python"
SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz"