aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-05-16 08:11:53 -0700
committerKhem Raj <raj.khem@gmail.com>2020-05-16 14:52:37 -0700
commit60e603f11ae1cca38553d18cf411f1a77207a97c (patch)
treef1a1e073d2f7014bf82758f0a5ee8d017b7eab95 /meta-networking
parentb260aa79693d2b6ba30e203197263ace73c12b4c (diff)
downloadmeta-openembedded-60e603f11ae1cca38553d18cf411f1a77207a97c.tar.gz
netplan: Depend on systemd if it is in distro
it needs to link with libsystemd when using systemd as init system Fixes Package libsystemd was not found in the pkg-config search path. Perhaps you should add the directory containing `libsystemd.pc' to the PKG_CONFIG_PATH environment variable Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan_0.98.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.98.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.98.bb
index db029a4b8a..9f123c70fb 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan_0.98.bb
+++ b/meta-networking/recipes-connectivity/netplan/netplan_0.98.bb
@@ -18,7 +18,8 @@ SRC_URI = " \
git://github.com/CanonicalLtd/netplan.git \
"
-DEPENDS = "glib-2.0 libyaml"
+DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+
RDEPENDS_${PN} = "python3 python3-core python3-pyyaml python3-netifaces python3-nose python3-coverage python3-pycodestyle python3-pyflakes util-linux-libuuid"
inherit pkgconfig systemd