aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-10-11 20:41:22 +0200
committerKhem Raj <raj.khem@gmail.com>2021-10-16 09:50:39 -0700
commit66a0f5b8eb7e16f82fae8233edca5082767f2f6b (patch)
treed9f8872e46d2420514139035fab370a4f53fceeb /meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch
parentcbd09fd1406adbfea8a41a9b4142f3b76ed5be6f (diff)
downloadmeta-openembedded-66a0f5b8eb7e16f82fae8233edca5082767f2f6b.tar.gz
mozjs: update 60.9.0 -> 91.1.0
The new release requires rust to build and at the same time allows updating to python 3.10; I took the opportunity to rewrite the recipe from scratch, drop all the old cruft and use the official, current upstream build system in it. All prior patches and tweaks have been dropped; I have no reasonable way to test them, so if something regressed for you I'm afraid it needs to be addressed after the fact. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch')
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch
new file mode 100644
index 0000000000..34861de7f2
--- /dev/null
+++ b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch
@@ -0,0 +1,32 @@
+From 9e37248870b2b955293754933c789ca00bca06ef Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Fri, 1 Oct 2021 13:00:24 +0200
+Subject: [PATCH] Cargo.toml: do not abort on panic
+
+OE's rust is configured to unwind, and this setting clashes with it/
+
+Upstream-Status: Inappropriate [oe-core specific]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ Cargo.toml | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Cargo.toml b/Cargo.toml
+index 09f3e7292f..0fff412569 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -57,7 +57,6 @@ panic = "abort"
+ opt-level = 2
+ rpath = false
+ debug-assertions = false
+-panic = "abort"
+
+ # Optimize build dependencies, because bindgen and proc macros / style
+ # compilation take more to run than to build otherwise.
+@@ -105,4 +104,4 @@ path = "third_party/rust/mio"
+
+ # Patch failure 0.1.8 to disable the backtrace feature by default. See bug 1608157.
+ [patch.crates-io.failure]
+-path = "third_party/rust/failure"
+\ No newline at end of file
++path = "third_party/rust/failure"