aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/files
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2014-06-18 11:12:15 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:47 +0200
commitfca32c0fcec0b9690f665cb5b764b4e5f5bfbf25 (patch)
tree10f58423c58d14e89b7a3e79bdb39d8dfacaddd7 /meta-oe/recipes-benchmark/libhugetlbfs/files
parent27981cbef19db115fa81704468721580dedfb1fd (diff)
downloadmeta-openembedded-fca32c0fcec0b9690f665cb5b764b4e5f5bfbf25.tar.gz
libhugetlbfs: arm 32bit support
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/files')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
new file mode 100644
index 0000000000..96f162dd94
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Submitted
+
+This patch adds support for arm32.
+
+Signed-off-by: Chunrong Guo <B40290@freescale.com>
+
+--- a/Makefileold 2014-06-17 21:55:23.131058918 -0500
++++ b/Makefile 2014-06-17 21:56:08.726098531 -0500
+@@ -59,6 +59,12 @@
+ TMPLIB32 = lib
+ CPPFLAGS += -DPPC_NO_SEGMENTS
+ else
++ifeq ($(ARCH),arm)
++CC32 = $(CC)
++TMPLIB32 = lib
++ELF32 += armelf_linux_eabi
++CUSTOM_LDSCRIPTS = no
++else
+ ifeq ($(ARCH),armv7l)
+ CC32 = $(CC)
+ TMPLIB32 = lib
+@@ -116,6 +122,7 @@
+ endif
+ endif
+ endif
++endif
+
+ ifdef CC32
+ OBJDIRS += obj32